summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2020-01-18 18:56:33 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-01-20 09:11:11 +0200
commite23cd83388e66120759d161267595b3548db4dce (patch)
tree3aa3b526f9e02146e94949cadf65adf1e0f4877c /app-crypt/acme-sh
parentapp-crypt/acme-sh: drop old ebuild (diff)
downloadgentoo-e23cd83388e66120759d161267595b3548db4dce.tar.gz
gentoo-e23cd83388e66120759d161267595b3548db4dce.tar.bz2
gentoo-e23cd83388e66120759d161267595b3548db4dce.zip
app-crypt/acme-sh: version bump to 2.8.5
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/14381 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-2.8.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 1d1aa063e507..caf9c58a1e18 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1,2 @@
DIST acme.sh-2.8.3.tar.gz 163573 BLAKE2B 7436932d79e732b8c419a588f4677ec0338c63d0dfc227e7410b151731e2fc4c028df81f459f7ad140dab857ebdebddab3173095e3efcfad0a971ff6762c8608 SHA512 15e147d0f07af91eab7274df50e274ae41a411c30ee7f6ebc8bcbcb601b66094fc1d8126bfb816caa27dbeb5222da20a25d1c79227bc70ddb6b5d0ce0dcb389e
+DIST acme.sh-2.8.5.tar.gz 176854 BLAKE2B 74eb9bbf4b99984ba77725c6751b713d6971503d1a8542472e75192afc9139705607f629e673af75b6ec7dab68b1a9ad2fd4676cda26871daf475487e28e0848 SHA512 db355d8c60c61b632c62dda376e71c438035d3eaf5630a6dc3ca241f6d988216f046e1588ccfe3da955aacb7897cefac5a8c7b6868f12af8f422182c52ed7b72
diff --git a/app-crypt/acme-sh/acme-sh-2.8.5.ebuild b/app-crypt/acme-sh/acme-sh-2.8.5.ebuild
new file mode 100644
index 000000000000..b34a4374029d
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-2.8.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An ACME Shell script"
+HOMEPAGE="https://github.com/Neilpang/acme.sh"
+SRC_URI="https://github.com/Neilpang/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/curl
+ || ( dev-libs/libressl dev-libs/openssl:0 )
+ || ( net-analyzer/netcat net-analyzer/openbsd-netcat )
+ || ( net-misc/socat www-servers/apache:2 www-servers/nginx )
+ virtual/cron"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ einstalldocs
+ newdoc dnsapi/README.md README-dnsapi.md
+ newdoc deploy/README.md README-deploy.md
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+ insinto /usr/share/acme.sh/dnsapi
+ doins -r dnsapi/*.sh
+ insinto /usr/share/acme.sh/deploy
+ doins -r deploy/*.sh
+ insinto /usr/share/acme.sh/notify
+ doins -r notify/*.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}