summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-04-20 00:02:07 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-04-20 00:02:27 -0700
commit5cb501ebcbcf690f77672d86a1c7117375b50036 (patch)
treeef93788c380b81908b65480963064407579f9383 /app-crypt/acme/acme-9999.ebuild
parentgames-fps/yamagi-quake2: remove old (diff)
downloadgentoo-5cb501ebcbcf690f77672d86a1c7117375b50036.tar.gz
gentoo-5cb501ebcbcf690f77672d86a1c7117375b50036.tar.bz2
gentoo-5cb501ebcbcf690f77672d86a1c7117375b50036.zip
app-crypt/acme: docs & missing indirect dep on dev-python/idna
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-crypt/acme/acme-9999.ebuild')
-rw-r--r--app-crypt/acme/acme-9999.ebuild24
1 files changed, 22 insertions, 2 deletions
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 9df5e0dbdae0..bfa507fa149c 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -21,10 +21,11 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="test"
+IUSE="doc test"
RDEPEND="
- >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
>=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
@@ -35,14 +36,33 @@ RDEPEND="
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
"
DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
)
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
"
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
python_test() {
nosetests -w ${PN} || die
}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}