summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-05-03 19:18:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-05-03 19:21:14 -0500
commit025c36c4b6ac6b3d4c9c9d8f437ed3f7e068bc69 (patch)
tree2e7178d0811e2fa92228bbf1287f77c45ae991e5 /app-crypt/acme
parentdev-python/josepy: 1.1.0 bup (diff)
downloadgentoo-025c36c4b6ac6b3d4c9c9d8f437ed3f7e068bc69.tar.gz
gentoo-025c36c4b6ac6b3d4c9c9d8f437ed3f7e068bc69.tar.bz2
gentoo-025c36c4b6ac6b3d4c9c9d8f437ed3f7e068bc69.zip
app-crypt/acme: 0.24.0 bup
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-0.24.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 2da0f20963db..7b4bc2839863 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -2,3 +2,4 @@ DIST certbot-0.21.1.tar.gz 1105663 BLAKE2B 7c36ec0504a144a2325528079374d103f6214
DIST certbot-0.22.0.tar.gz 1128134 BLAKE2B d4874bca6ac9f992d54b8fbab975bc020f448ed83896d0088c8ba0f1547fbc02a783038992408b9090fde4ad8386c81d85511094abcd42bc79b8883f05d4600c SHA512 406810e29a2637c420b9a8a3feb3a2ffb77bd740419cbcf46d10ab152a7252c765c058481b2a1f9a96cc426a9ae018bf90540fc0ebd54be1c8822c528cf1b605
DIST certbot-0.22.2.tar.gz 1128517 BLAKE2B 0b95ee9ab6b69b5d511b737d1cfc1eff543f1f0abeba9e60429dfe2dc389b39e19df10c77ea7c90ad8795640ae7602a7bc239c57cd1734863bf19d1f0c5eab67 SHA512 ca26be78d29728fc5c20a5290f2dde4d1f2090b7e2829c0b312acac4741ef56440cc21a9db77e3e0cfe59ce0f1f0ab2165cb6823af8a4e2a4528060ad683ffe9
DIST certbot-0.23.0.tar.gz 1144448 BLAKE2B 820c4e3a0245a4ccda90884e38093d4f95ebf8c06ccb93c80a277a69074a6ab3bac3451f4e8f9af6c1c36edd9d871e10de9240d847e6eeac5fb8e0fbcdb3cdcb SHA512 397562fa7f5ef5daea8ccf70dc21898f8b792dc6a07aa24035fa378da8af3dd5d0734c3fbf6080c28d17f050db46ec0ea637be81d4ce648fa5ab2add2cfd41ed
+DIST certbot-0.24.0.tar.gz 1149694 BLAKE2B 7c57d59ced97de77e0f98eb11a2bba418ee81ba0eb4506ebc010cb0060c92820617ba2a3464dd398bfec6dc86f4c2dc8e22461d76ae51ccfbb97afab3bbb3681 SHA512 b067da7eea54deb72ff4b516382cbe480ffebcb378489a2b0c52955f7399401d936d8d6587d88473d6f4fa9e864de94514941bde9727a5babbf2d6211ea61b20
diff --git a/app-crypt/acme/acme-0.24.0.ebuild b/app-crypt/acme/acme-0.24.0.ebuild
new file mode 100644
index 000000000000..610350856377
--- /dev/null
+++ b/app-crypt/acme/acme-0.24.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.0.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ nosetests -w ${PN} || die
+}