summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-06 19:30:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-06 19:30:05 +0100
commit496bb925650636af90c52e08e2a1f08399f4c295 (patch)
tree769e88ecf689e7f2d3ce9b27ae5f4d84bab7ac6d /app-crypt/acme
parentdev-texlive/texlive-genericextra: arm stable, bug #550840 (diff)
downloadgentoo-496bb925650636af90c52e08e2a1f08399f4c295.tar.gz
gentoo-496bb925650636af90c52e08e2a1f08399f4c295.tar.bz2
gentoo-496bb925650636af90c52e08e2a1f08399f4c295.zip
app-crypt/acme: Add support for regular releases
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/acme-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 1f9364034341..1df4590ea219 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -5,16 +5,24 @@
EAPI=5
PYTHON_COMPAT=(python{2_7,3_4,3_5})
-EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
-
-inherit git-r3 distutils-r1
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+ KEYWORDS=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/letsencrypt/archive/v${PV}.tar.gz -> letsencrypt-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/letsencrypt-${PV}/acme
+fi
+
+inherit distutils-r1
DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
@@ -30,8 +38,6 @@ RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"
-S=${WORKDIR}/${P}/${PN}
-
python_test() {
nosetests -w ${PN} || die
}