summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2021-05-01 09:38:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-10-25 10:58:44 +0300
commit0ecef0755e33d52334160fa341071807664595cb (patch)
tree643ab04c7179aa87485c50ba91720fc3546204e7 /app-crypt/adcli/adcli-0.9.1.ebuild
parentgnustep-libs/cenonlibrary: bump EAPI (diff)
downloadgentoo-0ecef0755e33d52334160fa341071807664595cb.tar.gz
gentoo-0ecef0755e33d52334160fa341071807664595cb.tar.bz2
gentoo-0ecef0755e33d52334160fa341071807664595cb.zip
app-crypt/adcli: new package
Tool for performing actions on an Active Directory domain. Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/adcli/adcli-0.9.1.ebuild')
-rw-r--r--app-crypt/adcli/adcli-0.9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/adcli/adcli-0.9.1.ebuild b/app-crypt/adcli/adcli-0.9.1.ebuild
new file mode 100644
index 000000000000..8dd6b2412c4e
--- /dev/null
+++ b/app-crypt/adcli/adcli-0.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tool for performing actions on an Active Directory domain"
+HOMEPAGE="https://www.freedesktop.org/software/realmd/adcli/adcli.html"
+SRC_URI="https://gitlab.freedesktop.org/realmd/adcli/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-crypt/mit-krb5
+ net-nds/openldap[sasl]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ app-text/docbook-xml-dtd:4.3
+ app-text/xmlto
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc)
+}