summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-09 15:16:40 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-09 15:16:40 +0200
commit6f0ee8b4b735f72e1fd724df35b1b551ef831963 (patch)
tree47a626b2c57a915c4db3d1995eb3b64553e40560 /app-crypt/aespipe
parentapp-crypt/aespipe: drop 2.4e (diff)
downloadgentoo-6f0ee8b4b735f72e1fd724df35b1b551ef831963.tar.gz
gentoo-6f0ee8b4b735f72e1fd724df35b1b551ef831963.tar.bz2
gentoo-6f0ee8b4b735f72e1fd724df35b1b551ef831963.zip
app-crypt/aespipe: update EAPI 7 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/aespipe')
-rw-r--r--app-crypt/aespipe/aespipe-2.4f-r1.ebuild (renamed from app-crypt/aespipe/aespipe-2.4f.ebuild)9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-crypt/aespipe/aespipe-2.4f.ebuild b/app-crypt/aespipe/aespipe-2.4f-r1.ebuild
index 3adf1b9778ab..c8ed90346146 100644
--- a/app-crypt/aespipe/aespipe-2.4f.ebuild
+++ b/app-crypt/aespipe/aespipe-2.4f-r1.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit flag-o-matic
DESCRIPTION="Encrypts data from stdin to stdout"
HOMEPAGE="https://loop-aes.sourceforge.net"
SRC_URI="https://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_padlock static"
-RDEPEND="app-arch/sharutils
- app-crypt/gnupg"
-S="${WORKDIR}/${PN}-v${PV}"
+RDEPEND="
+ app-arch/sharutils
+ app-crypt/gnupg"
src_configure() {
use static && append-ldflags -static