summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-08-04 22:27:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-08-04 22:29:07 -0500
commit59ea0be65c8892a72b5f68e022882ad35c8dfd05 (patch)
treee89ea90514f1bc2c9226c30297a51df3dda4b98d /app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild
parentapp-crypt/certbot: 1.18.0 bump (diff)
downloadgentoo-59ea0be65c8892a72b5f68e022882ad35c8dfd05.tar.gz
gentoo-59ea0be65c8892a72b5f68e022882ad35c8dfd05.tar.bz2
gentoo-59ea0be65c8892a72b5f68e022882ad35c8dfd05.zip
app-crypt/certbot-apache: 1.18.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild
new file mode 100644
index 000000000000..7f0e325d33df
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"