summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-03-04 10:19:43 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-03-04 10:22:04 -0600
commit084f0ada27b89aad4fd1829d2c50e9c449ef2269 (patch)
treeaa43a2a59e0f1d4c4de3e70ca34e54a1dcffd0d1 /app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild
parentapp-crypt/certbot: 1.3.0 bump (diff)
downloadgentoo-084f0ada27b89aad4fd1829d2c50e9c449ef2269.tar.gz
gentoo-084f0ada27b89aad4fd1829d2c50e9c449ef2269.tar.bz2
gentoo-084f0ada27b89aad4fd1829d2c50e9c449ef2269.zip
app-crypt/certbot-apache: 1.3.0 bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild
new file mode 100644
index 000000000000..56e71bffc582
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}