summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-25 19:05:52 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-25 19:05:52 -0600
commit23b8b2b9a381cdda0b9c2a99415b38e0283b8d42 (patch)
tree82d5c3ee495eff596660b33b1c7d0ffb22439be0 /app-crypt/certbot-apache
parentapp-crypt/certbot: 0.21.1 bup (diff)
downloadgentoo-23b8b2b9a381cdda0b9c2a99415b38e0283b8d42.tar.gz
gentoo-23b8b2b9a381cdda0b9c2a99415b38e0283b8d42.tar.bz2
gentoo-23b8b2b9a381cdda0b9c2a99415b38e0283b8d42.zip
app-crypt/certbot-apache: 0.21.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.21.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 772d0f15369a..d0dea856b8de 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -2,3 +2,4 @@ DIST certbot-0.18.2.tar.gz 1044019 BLAKE2B d198252c1e3e24a80bcadeecde7fd133e4540
DIST certbot-0.19.0.tar.gz 1061557 BLAKE2B 4f1c623276cbcc88d414dd9d135b65f472d1e35cfef74901fb8031d40d414266870229b6aaf60a4bfde983c7e930819e5e7326d5cfa3cbffb155e3a9c724883a SHA512 d29c9e2041171f2574bf2ee9ff7442b80b261a03f9e82e4dd40aad0617730aca6bff17fcc728496bda4133f86a4894cf21d083dacb0d0df2dec11d23e4e1541b
DIST certbot-0.20.0.tar.gz 1108139 BLAKE2B 6af07dd245912741592761bd11160c081e278e5f48b69747669aa6146d81cc7ad6f0d9c7b4bf31ad137d51bd378f670e5e5d7318efe7b3b5463d52515a5df257 SHA512 92c128bc955a576a1eb568d39b3a5568f9bd841acefaa455d716ce5036312d0ad67b3dcfcf960b15abdd39c1f34f82ffe2ebca0722628c5c804fc5472a6c0546
DIST certbot-0.21.0.tar.gz 1105665 BLAKE2B c7fea5f9fd6a0f68112897923fe96c854751789c6ba71ad38c333c259d556431ccc53658eef520f2518b42ff26748bc6736f3deff97cbfee4900305b1cd24fa7 SHA512 87d1f2b5153f8fc6a5cf1ee3e6ba084464d2094ef0ae8955d4ac3c75de759cd62c54465186a21b4d4205193f410cbfcb93f4af4f29bfdb21f7cc881a38c4340f
+DIST certbot-0.21.1.tar.gz 1105663 BLAKE2B 7c36ec0504a144a2325528079374d103f6214252c01ba0bcaf26378950fe5cd54010abe756d80b1c0c30740442a184417f0b2bd7ffea91edeb70c59dfee2349e SHA512 6f3ffba7dc06bcc2a6b9835906331753ee2715192e7a49562314480069f22e4a66bb26f04dc4bbdfb0ab40998220d0c9b77fb0351e042116b02996fb2da699d2
diff --git a/app-crypt/certbot-apache/certbot-apache-0.21.1.ebuild b/app-crypt/certbot-apache/certbot-apache-0.21.1.ebuild
new file mode 100644
index 000000000000..bcdba5a9d286
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.21.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}