summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-04-28 21:59:02 +0200
committerAmy Winston <amynka@gentoo.org>2016-04-28 22:03:04 +0200
commit5e8d5a93f0150081cccc19dae5a6a9a4670501a7 (patch)
tree96a7a662ef9d2592a8a7ab48f91b3e09cd43158c /app-crypt/codecrypt/codecrypt-1.7.5.ebuild
parentwww-client/qupzilla: version bump (diff)
downloadgentoo-5e8d5a93f0150081cccc19dae5a6a9a4670501a7.tar.gz
gentoo-5e8d5a93f0150081cccc19dae5a6a9a4670501a7.tar.bz2
gentoo-5e8d5a93f0150081cccc19dae5a6a9a4670501a7.zip
app-crypt/codecrypt: version bump 1.7.5. By exa
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-crypt/codecrypt/codecrypt-1.7.5.ebuild')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.7.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.7.5.ebuild b/app-crypt/codecrypt/codecrypt-1.7.5.ebuild
new file mode 100644
index 000000000000..8c22ebeec858
--- /dev/null
+++ b/app-crypt/codecrypt/codecrypt-1.7.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Post-quantum cryptography tool"
+HOMEPAGE="http://e-x-a.org/codecrypt/"
+SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+cryptopp"
+
+DEPEND="dev-libs/gmp:=
+ cryptopp? ( dev-libs/crypto++ )
+ sci-libs/fftw:3.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ # workaround -- gentoo is missing crypto++ pkg-config file
+ sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/LDFLAGS="$LDFLAGS -lcrypto++"/' configure.ac
+ ./autogen.sh
+}
+
+src_configure() {
+ econf \
+ $(use_with cryptopp )
+}