summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-02 21:25:24 +0000
committerSam James <sam@gentoo.org>2021-06-02 21:50:26 +0000
commit458a9a074ce9853c3d39e5b1a6844b34bb6ef751 (patch)
tree294d8b38be76ee476e09a2deb31d99a9ba4377a2 /app-crypt/dieharder/dieharder-3.31.1-r4.ebuild
parentapp-office/calligra: subscribe to sci-libs/gsl subslot (diff)
downloadgentoo-458a9a074ce9853c3d39e5b1a6844b34bb6ef751.tar.gz
gentoo-458a9a074ce9853c3d39e5b1a6844b34bb6ef751.tar.bz2
gentoo-458a9a074ce9853c3d39e5b1a6844b34bb6ef751.zip
app-crypt/dieharder: subscribe to sci-libs/gsl subslot
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/dieharder/dieharder-3.31.1-r4.ebuild')
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1-r4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/dieharder/dieharder-3.31.1-r4.ebuild b/app-crypt/dieharder/dieharder-3.31.1-r4.ebuild
new file mode 100644
index 000000000000..8bae5f15b9a4
--- /dev/null
+++ b/app-crypt/dieharder/dieharder-3.31.1-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="An advanced suite for testing the randomness of RNGs"
+HOMEPAGE="https://www.phy.duke.edu/~rgb/General/dieharder.php"
+SRC_URI="https://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+RESTRICT="test" # Way too long
+
+RDEPEND="sci-libs/gsl:="
+DEPEND="${RDEPEND}"
+BDEPEND=" doc? ( dev-tex/latex2html )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-urandom-64bit.patch
+ "${FILESDIR}"/${P}-cross-compile.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fcommon
+ econf --disable-static
+}
+
+src_compile() {
+ emake -j1
+ use doc && emake -C manual
+}
+
+src_install() {
+ if use doc; then
+ DOCS=( ChangeLog manual/dieharder.pdf manual/dieharder.ps )
+ HTML_DOCS=( dieharder.html )
+ fi
+
+ default
+
+ docinto dieharder
+ dodoc dieharder/{NOTES,README}
+ docinto libdieharder
+ dodoc libdieharder/{NOTES,README}
+
+ find "${ED}" -name '*.la' -delete || die
+}