summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-04-20 15:58:33 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-20 16:29:35 +0200
commit0c2672e554d79c6075e36447099567933a528037 (patch)
treefad8de80c2792923b9551dc87a30ccc48eb6eb0e /app-crypt/efitools/efitools-1.8.1.ebuild
parentnet-misc/ofono: fix license (diff)
downloadgentoo-0c2672e554d79c6075e36447099567933a528037.tar.gz
gentoo-0c2672e554d79c6075e36447099567933a528037.tar.bz2
gentoo-0c2672e554d79c6075e36447099567933a528037.zip
app-crypt/efitools: Bump to version 1.8.1
Closes: https://bugs.gentoo.org/652090 Closes: https://bugs.gentoo.org/652066 Closes: https://github.com/gentoo/gentoo/pull/7747 Package-Manager: Portage-2.3.30, Repoman-2.3.9
Diffstat (limited to 'app-crypt/efitools/efitools-1.8.1.ebuild')
-rw-r--r--app-crypt/efitools/efitools-1.8.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/efitools/efitools-1.8.1.ebuild b/app-crypt/efitools/efitools-1.8.1.ebuild
new file mode 100644
index 000000000000..093ce11c7611
--- /dev/null
+++ b/app-crypt/efitools/efitools-1.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools for manipulating UEFI secure boot platforms"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jejb/efitools.git"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git/snapshot/efitools-1.8.1.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libressl"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-apps/util-linux"
+
+DEPEND="${RDEPEND}
+ app-crypt/sbsigntool
+ dev-perl/File-Slurp-Unicode
+ sys-apps/help2man
+ sys-boot/gnu-efi
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Respect users CFLAGS
+ sed -i -e 's/CFLAGS.*= -O2 -g/CFLAGS += /' Make.rules || die
+
+ # Respect users LDFLAGS
+ sed -i -e 's/LDFLAGS/LIBS/g' Make.rules || die
+ sed -i -e 's/\$(CC)/& $(LDFLAGS)/g' Makefile || die
+
+ # Run 'default', to apply user patches
+ default
+}