summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-22 02:52:28 +0100
committerSam James <sam@gentoo.org>2023-06-22 02:52:28 +0100
commitae1e332058fc483a5d8d7804d34f369f4566638e (patch)
tree77a15ee87a578804bdde17e5b99067582952aefb /app-crypt/efitools/efitools-1.9.2-r1.ebuild
parentprofiles/features/llvm: mask binutils[pgo] (diff)
downloadgentoo-ae1e332058fc483a5d8d7804d34f369f4566638e.tar.gz
gentoo-ae1e332058fc483a5d8d7804d34f369f4566638e.tar.bz2
gentoo-ae1e332058fc483a5d8d7804d34f369f4566638e.zip
app-crypt/efitools: filter LTO
Calls LD directly and doesn't respect LDFLAGS. Low level tool with a history of e.g. segfaulting with new openssl, so let's not risk anything anyway. Closes: https://bugs.gentoo.org/908813 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/efitools/efitools-1.9.2-r1.ebuild')
-rw-r--r--app-crypt/efitools/efitools-1.9.2-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-crypt/efitools/efitools-1.9.2-r1.ebuild b/app-crypt/efitools/efitools-1.9.2-r1.ebuild
index c10f01e423d3..0deba136bb4c 100644
--- a/app-crypt/efitools/efitools-1.9.2-r1.ebuild
+++ b/app-crypt/efitools/efitools-1.9.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -48,5 +48,9 @@ src_prepare() {
}
src_configure() {
+ # Calls LD directly, doesn't respect LDFLAGS. Low level package anyway.
+ # See bug #908813.
+ filter-lto
+
tc-export AR CC LD NM OBJCOPY PKG_CONFIG
}