summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-03 17:18:42 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-03 17:19:50 +0100
commit0fa758d4ebf7f0be6b99dc8783370a777499afb7 (patch)
treec9379dea772ac8e822c042435ba53bb393dd5201 /app-crypt/glep63-check/glep63-check-11.ebuild
parentapp-portage/gverify: Enable py3.12 (diff)
downloadgentoo-0fa758d4ebf7f0be6b99dc8783370a777499afb7.tar.gz
gentoo-0fa758d4ebf7f0be6b99dc8783370a777499afb7.tar.bz2
gentoo-0fa758d4ebf7f0be6b99dc8783370a777499afb7.zip
app-crypt/glep63-check: Fix running tests with modern Portage
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt/glep63-check/glep63-check-11.ebuild')
-rw-r--r--app-crypt/glep63-check/glep63-check-11.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-crypt/glep63-check/glep63-check-11.ebuild b/app-crypt/glep63-check/glep63-check-11.ebuild
index 37398e67dec8..c1d3c5a0eee9 100644
--- a/app-crypt/glep63-check/glep63-check-11.ebuild
+++ b/app-crypt/glep63-check/glep63-check-11.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -12,17 +12,28 @@ DESCRIPTION="GLEP 63 compliance checker for OpenPGP keys"
HOMEPAGE="https://github.com/projg2/glep63-check/"
SRC_URI="
https://github.com/projg2/glep63-check/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+ -> ${P}.tar.gz
+"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-RDEPEND="app-crypt/gnupg"
+RDEPEND="
+ app-crypt/gnupg
+"
DEPEND="
test? (
>=app-crypt/gnupg-2.3.3
sys-libs/libfaketime
- )"
+ )
+"
distutils_enable_tests unittest
+
+src_test() {
+ local -x GNUPGHOME=${T}/gnupg
+ mkdir -p "${GNUPGHOME}" || die
+
+ distutils-r1_src_test
+}