summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2016-11-22 19:17:17 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2016-11-22 19:31:18 +0100
commit40c193d57556e799c16e8cac356947a815b529c7 (patch)
tree294a80a6c4453596cf58ea358562621fe2bc6920 /app-crypt/gnupg/gnupg-2.1.16.ebuild
parentapp-vim/gist: Clean up old. (diff)
downloadgentoo-40c193d57556e799c16e8cac356947a815b529c7.tar.gz
gentoo-40c193d57556e799c16e8cac356947a815b529c7.tar.bz2
gentoo-40c193d57556e799c16e8cac356947a815b529c7.zip
app-crypt/gnupg: Minor changes to 2.1.16
For now tools subdir always needs to be built, even though the use flag controls whether some of the resulting binaries are installed or not, as e.g gpg-connect-agent and gpg-wks-client is expected to be installed unconditionally. Given that tools subdir is a cheap build, this doesn't constitute much of an actual issue, but upstream is notified. Gentoo-Bug: 600208 Add patch to mitigate test failure due to overlong socket path. Package-Manager: portage-2.3.2
Diffstat (limited to 'app-crypt/gnupg/gnupg-2.1.16.ebuild')
-rw-r--r--app-crypt/gnupg/gnupg-2.1.16.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-crypt/gnupg/gnupg-2.1.16.ebuild b/app-crypt/gnupg/gnupg-2.1.16.ebuild
index 4fc5fd6fc09c..62dc0e9b34d3 100644
--- a/app-crypt/gnupg/gnupg-2.1.16.ebuild
+++ b/app-crypt/gnupg/gnupg-2.1.16.ebuild
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
SLOT="0"
-IUSE="bzip2 doc +gnutls ldap nls readline selinux +smartcard tofu +tools usb wks-server"
+IUSE="bzip2 doc +gnutls ldap nls readline selinux +smartcard tofu tools usb wks-server"
COMMON_DEPEND_LIBS="
>=dev-libs/npth-1.2
@@ -50,6 +50,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
default
+ epatch "${FILESDIR}/${PN}-2.1.16-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch"
epatch_user
}
@@ -88,7 +89,7 @@ src_configure() {
$(use_enable nls) \
$(use_with readline) \
$(use_enable tofu) \
- $(use_enable tools) \
+ --enable-tools \
$(use_enable wks-server wks-tools) \
CC_FOR_BUILD="$(tc-getBUILD_CC)"
}