summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/gorilla
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/gorilla')
-rw-r--r--app-crypt/gorilla/Manifest1
-rw-r--r--app-crypt/gorilla/files/gorilla-script-destdir.patch17
-rw-r--r--app-crypt/gorilla/gorilla-1.4-r1.ebuild41
-rw-r--r--app-crypt/gorilla/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/app-crypt/gorilla/Manifest b/app-crypt/gorilla/Manifest
new file mode 100644
index 000000000000..b4cc079b4a5b
--- /dev/null
+++ b/app-crypt/gorilla/Manifest
@@ -0,0 +1 @@
+DIST gorilla-1.4.tar.gz 190766 SHA256 3184ff802d0f96250302e2ce1a966d5eca328e8e0becc44e037208af32ee0551 SHA512 56328068506309e99f9bc8b095048840eabacb794c742b36c4b855501d2973646e6e5ef7755f0aa29e636c5f5463fa1b24f0f627cb691511e4a48e1f062ce44b WHIRLPOOL 63b94f0daad92bb734c4319f82b0606ab990a552902f38a6c11a64da7917d000bf43b72a2754d2b72d310e57cffdbcbdcf9427d4c030343cb76cf588629fa57c
diff --git a/app-crypt/gorilla/files/gorilla-script-destdir.patch b/app-crypt/gorilla/files/gorilla-script-destdir.patch
new file mode 100644
index 000000000000..e18fcd80e3ec
--- /dev/null
+++ b/app-crypt/gorilla/files/gorilla-script-destdir.patch
@@ -0,0 +1,17 @@
+--- gorilla-1.4/gorilla.in 2006-07-14 13:29:33.000000000 -0400
++++ gorilla-1.4/gorilla.in.new 2006-07-14 13:33:01.000000000 -0400
+@@ -1,10 +1,13 @@
+ #! /bin/sh
+ # the next line restarts using wish \
+ exec @wish@ "$0" ${1+"$@"}
++
+ set myName [info script]
++set myGorilla /opt/gorilla-1.4/gorilla.tcl
++
+ if {![catch {
+ set linkName [file readlink $myName]
+ }]} {
+ set myName $linkName
+ }
+-source [file join [file dirname $myName] gorilla.tcl]
++source [file join [file dirname $myName] $myGorilla]
diff --git a/app-crypt/gorilla/gorilla-1.4-r1.ebuild b/app-crypt/gorilla/gorilla-1.4-r1.ebuild
new file mode 100644
index 000000000000..e90c85863895
--- /dev/null
+++ b/app-crypt/gorilla/gorilla-1.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Password Safe in secure way with GUI interface"
+HOMEPAGE="https://github.com/zdia/gorilla/wiki"
+SRC_URI="https://github.com/zdia/gorilla/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/tcl-8.4.19:0
+ >=dev-lang/tk-8.4.19:0
+ dev-tcltk/iwidgets
+ dev-tcltk/bwidget"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-script-destdir.patch
+}
+
+src_configure() {
+ ./configure || die "econf failed"
+}
+src_compile() { :; }
+
+src_install() {
+ PREFIX="/opt/${P}"
+
+ insinto ${PREFIX}
+ doins -r gorilla.tcl isaac.tcl twofish sha1 blowfish pwsafe pics
+
+ dobin gorilla
+}
diff --git a/app-crypt/gorilla/metadata.xml b/app-crypt/gorilla/metadata.xml
new file mode 100644
index 000000000000..a7e9dbdcf257
--- /dev/null
+++ b/app-crypt/gorilla/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zdia/gorilla</remote-id>
+ </upstream>
+</pkgmetadata>