summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/hashcat-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/hashcat-bin')
-rw-r--r--app-crypt/hashcat-bin/Manifest3
-rw-r--r--app-crypt/hashcat-bin/hashcat-bin-0.46.ebuild111
-rw-r--r--app-crypt/hashcat-bin/hashcat-bin-0.47.ebuild111
-rw-r--r--app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild111
-rw-r--r--app-crypt/hashcat-bin/metadata.xml10
5 files changed, 346 insertions, 0 deletions
diff --git a/app-crypt/hashcat-bin/Manifest b/app-crypt/hashcat-bin/Manifest
new file mode 100644
index 000000000000..cb3de87f63c7
--- /dev/null
+++ b/app-crypt/hashcat-bin/Manifest
@@ -0,0 +1,3 @@
+DIST hashcat-0.46.7z 1581813 SHA256 bf8ba2ef197199b3be156aa85fb5d085ebf5e29e76f18cf66e81830fe654e84f SHA512 e313af6e0edc27a7fbf93c89eda862579868b80c36b4c0237991321ebe55ca0bc5b62afe35eba7852212e97c28c5a07d73929a2a503a683bf3f2c9e8a6891a82 WHIRLPOOL 766b69a34e6ffbed22c1e23d0c1bb2a4073c431c9e5dfd6a640691d021d298e6a3de8a778eab6fd7a666f626feb1bea85a7fbf37ec88868dd21045732190ef9a
+DIST hashcat-0.47.7z 1651995 SHA256 239acb25b88d529314f2f98af0d6a66772e886c9efbb4ed2b94b7587c9a68455 SHA512 a43b3534fdb6fbe6bcb49d48430f13e77c7ead33da2dad281fd84aa8f0f7be28e30f938339f59a37d690deb7167d6d5ad9d29d987feb9528006483136642c934 WHIRLPOOL 75d0d3c9a26358a872c08e48fd24ea29c8bf85ce36e7cd6d04135e2a4ed6ab82f4df59a3855b84318784a12ff73775b30f82112c0840dd7f4dcd9ca168932b10
+DIST hashcat-0.49.7z 2423049 SHA256 02ca88393ecf33aaa0905592ca71e90671338c9540f212b3ad0f4666a93b406d SHA512 3e51a803c87de4f659ad3f72337234392140cd714a40eb221cb7697aa6f8df4da92ed7a7852deae5fdf36439c46fe4eaa312ed45a72dedbf13eaa6d9767e95bb WHIRLPOOL 5cbf4b4bca8371a47c5349a0e4ab825e7401a2363558eeeea9942d0652b133cc9fc11229e6ea676fbd6a179864abadfdfa5bb16a4fb9387ea74111d3ccda4bff
diff --git a/app-crypt/hashcat-bin/hashcat-bin-0.46.ebuild b/app-crypt/hashcat-bin/hashcat-bin-0.46.ebuild
new file mode 100644
index 000000000000..c865dff93d8d
--- /dev/null
+++ b/app-crypt/hashcat-bin/hashcat-bin-0.46.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P="hashcat-${PV}"
+
+inherit eutils pax-utils
+DESCRIPTION="An multi-threaded multihash cracker"
+HOMEPAGE="http://hashcat.net/hashcat/"
+
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+#license applies to this version per http://hashcat.net/forum/thread-1348.html
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~amd64-linux ~x64-macos ~x86 ~x86-linux"
+
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/hashcat-cli*.bin
+ opt/${PN}/hashcat-cli64.app"
+
+has_xop() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __XOP__ 1"
+}
+
+has_avx() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __AVX__ 1"
+}
+
+src_install() {
+ dodoc docs/*
+ rm -r *.exe docs || die
+ use x86 || { rm hashcat-cli32.bin || die; }
+ use amd64 || { rm hashcat-cli64.bin || die; }
+ use x64-macos || { rm hashcat-cli64.app || die; }
+ has_avx || { rm hashcat-cliAVX.bin || die; }
+ has_xop || { rm hashcat-cliXOP.bin || die; }
+
+ #I assume this is needed but I didn't check
+ pax-mark m hashcat-cli*.bin
+
+ insinto /opt/${PN}
+ doins -r "${S}"/*
+
+ dodir /opt/bin
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli32.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli32.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli32.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli32.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli32.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli32.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliAVX.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliAVX.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliAVX.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliAVX.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliAVX.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliAVX.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliXOP.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliXOP.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliXOP.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliXOP.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliXOP.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliXOP.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.app ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.app
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.app
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.app is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.app \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.app
+ fi
+}
diff --git a/app-crypt/hashcat-bin/hashcat-bin-0.47.ebuild b/app-crypt/hashcat-bin/hashcat-bin-0.47.ebuild
new file mode 100644
index 000000000000..c69a1a039317
--- /dev/null
+++ b/app-crypt/hashcat-bin/hashcat-bin-0.47.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="hashcat-${PV}"
+
+inherit eutils pax-utils
+DESCRIPTION="An multi-threaded multihash cracker"
+HOMEPAGE="http://hashcat.net/hashcat/"
+
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+#license applies to this version per http://hashcat.net/forum/thread-1348.html
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~amd64-linux ~x64-macos ~x86 ~x86-linux"
+
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/hashcat-cli*.bin
+ opt/${PN}/hashcat-cli64.app"
+
+has_xop() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __XOP__ 1"
+}
+
+has_avx() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __AVX__ 1"
+}
+
+src_install() {
+ dodoc docs/*
+ rm -r *.exe docs || die
+ use x86 || { rm hashcat-cli32.bin || die; }
+ use amd64 || { rm hashcat-cli64.bin || die; }
+ use x64-macos || { rm hashcat-cli64.app || die; }
+ has_avx || { rm hashcat-cliAVX.bin || die; }
+ has_xop || { rm hashcat-cliXOP.bin || die; }
+
+ #I assume this is needed but I didn't check
+ pax-mark m hashcat-cli*.bin
+
+ insinto /opt/${PN}
+ doins -r "${S}"/*
+
+ dodir /opt/bin
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli32.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli32.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli32.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli32.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli32.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli32.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliAVX.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliAVX.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliAVX.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliAVX.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliAVX.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliAVX.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliXOP.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliXOP.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliXOP.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliXOP.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliXOP.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliXOP.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.app ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.app
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.app
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.app is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.app \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.app
+ fi
+}
diff --git a/app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild b/app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild
new file mode 100644
index 000000000000..0e505aba9bb8
--- /dev/null
+++ b/app-crypt/hashcat-bin/hashcat-bin-0.49.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="hashcat-${PV}"
+
+inherit eutils pax-utils
+DESCRIPTION="An multi-threaded multihash cracker"
+HOMEPAGE="http://hashcat.net/hashcat/"
+
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+#license applies to this version per http://hashcat.net/forum/thread-1348.html
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~amd64-linux ~x64-macos ~x86 ~x86-linux"
+
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/hashcat-cli*.bin
+ opt/${PN}/hashcat-cli64.app"
+
+has_xop() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __XOP__ 1"
+}
+
+has_avx() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __AVX__ 1"
+}
+
+src_install() {
+ dodoc docs/*
+ rm -r *.exe docs || die
+ use x86 || { rm hashcat-cli32.bin || die; }
+ use amd64 || { rm hashcat-cli64.bin || die; }
+ use x64-macos || { rm hashcat-cli64.app || die; }
+ has_avx || { rm hashcat-cliAVX.bin || die; }
+ has_xop || { rm hashcat-cliXOP.bin || die; }
+
+ #I assume this is needed but I didn't check
+ pax-mark m hashcat-cli*.bin
+
+ insinto /opt/${PN}
+ doins -r "${S}"/*
+
+ dodir /opt/bin
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli32.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli32.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli32.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli32.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli32.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli32.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliAVX.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliAVX.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliAVX.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliAVX.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliAVX.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliAVX.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliXOP.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliXOP.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliXOP.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliXOP.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliXOP.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliXOP.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.app ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.app
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.app
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.app is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.app \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.app
+ fi
+}
diff --git a/app-crypt/hashcat-bin/metadata.xml b/app-crypt/hashcat-bin/metadata.xml
new file mode 100644
index 000000000000..88e9eb110229
--- /dev/null
+++ b/app-crypt/hashcat-bin/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+</pkgmetadata>
+