summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-12-07 11:08:14 -0500
committerZero_Chaos <zerochaos@gentoo.org>2017-12-07 11:08:30 -0500
commitd8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead (patch)
treed3827c5ddfed2a55a9e09fb25ebff1e0cda88e61 /app-crypt/hashcat/hashcat-4.0.1.ebuild
parentapp-emulation/libvirt: Update apparmor profiles (diff)
downloadgentoo-d8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead.tar.gz
gentoo-d8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead.tar.bz2
gentoo-d8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead.zip
app-crypt/hashcat: bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-crypt/hashcat/hashcat-4.0.1.ebuild')
-rw-r--r--app-crypt/hashcat/hashcat-4.0.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/hashcat/hashcat-4.0.1.ebuild b/app-crypt/hashcat/hashcat-4.0.1.ebuild
new file mode 100644
index 000000000000..d867ebec2e8e
--- /dev/null
+++ b/app-crypt/hashcat/hashcat-4.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils pax-utils multilib
+
+DESCRIPTION="World's fastest and most advanced password recovery utility"
+HOMEPAGE="https://github.com/hashcat/hashcat"
+SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="custom-cflags video_cards_nvidia"
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #do not strip
+ sed -i "/LFLAGS += -s/d" src/Makefile
+ #do not add random CFLAGS
+ sed -i "s/-O2//" src/Makefile || die
+ export PREFIX=/usr
+ export LIBRARY_FOLDER="/usr/$(get_libdir)"
+ eapply_user
+}
+
+src_compile() {
+ default
+ pax-mark -mr hashcat
+}
+
+src_test() {
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ #elif use vidia_cards_fglrx; then
+ # addwrite /dev/ati
+ fi
+ #this always exits with 255 despite success
+ #./hashcat -b -m 2500 || die "Test failed"
+ ./hashcat -a 3 -m 1500 nQCk49SiErOgk || die "Test failed"
+}