summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-29 07:01:20 +0000
committerSam James <sam@gentoo.org>2021-05-29 07:02:03 +0000
commit0179cbdaf16fc35f9b1ace3bf48b14014c615a18 (patch)
tree5253760d5a6bfff9248c13794a066f67fde158f8 /app-crypt/hashcat/hashcat-9999.ebuild
parentcommon-lisp-3.eclass: Don't run sbcl interactively (diff)
downloadgentoo-0179cbdaf16fc35f9b1ace3bf48b14014c615a18.tar.gz
gentoo-0179cbdaf16fc35f9b1ace3bf48b14014c615a18.tar.bz2
gentoo-0179cbdaf16fc35f9b1ace3bf48b14014c615a18.zip
app-crypt/hashcat: use bundled unrar for now
Unreleased changes upstream. Closes: https://bugs.gentoo.org/792720 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/hashcat/hashcat-9999.ebuild')
-rw-r--r--app-crypt/hashcat/hashcat-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-crypt/hashcat/hashcat-9999.ebuild b/app-crypt/hashcat/hashcat-9999.ebuild
index dc3813e63de6..1adb6223b74a 100644
--- a/app-crypt/hashcat/hashcat-9999.ebuild
+++ b/app-crypt/hashcat/hashcat-9999.ebuild
@@ -60,13 +60,14 @@ src_prepare() {
src_compile() {
tc-export CC CXX AR
+ # Use bundled unrar for now, bug #792720
emake \
SHARED=1 \
PRODUCTION=1 \
ENABLE_BRAIN=$(usex brain 1 0) \
USE_SYSTEM_LZMA=0 \
USE_SYSTEM_OPENCL=1 \
- USE_SYSTEM_UNRAR=1 \
+ USE_SYSTEM_UNRAR=0 \
USE_SYSTEM_ZLIB=1 \
USE_SYSTEM_XXHASH=1 \
VERSION_PURE="${PV}"