summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-03-03 11:44:02 -0500
committerZero_Chaos <zerochaos@gentoo.org>2017-03-03 11:44:25 -0500
commit0a8d15747a6a53bbb300303cc0d596caf5e3bf22 (patch)
tree9549cd7368e720353adf4554bd4f0be52741eb24 /app-crypt/hashcat
parentnet-wireless/neard: fix typo in license header #611528 (diff)
downloadgentoo-0a8d15747a6a53bbb300303cc0d596caf5e3bf22.tar.gz
gentoo-0a8d15747a6a53bbb300303cc0d596caf5e3bf22.tar.bz2
gentoo-0a8d15747a6a53bbb300303cc0d596caf5e3bf22.zip
app-crypt/hashcat: bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-crypt/hashcat')
-rw-r--r--app-crypt/hashcat/Manifest1
-rw-r--r--app-crypt/hashcat/hashcat-3.40.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/hashcat/Manifest b/app-crypt/hashcat/Manifest
index 3a6c9ef6833e..da97a614a44e 100644
--- a/app-crypt/hashcat/Manifest
+++ b/app-crypt/hashcat/Manifest
@@ -1 +1,2 @@
DIST hashcat-3.30.tar.gz 3970267 SHA256 d255147cbbf6b3cacea81b818ee228170969b61487dd7d49b339fc94dfe53e8e SHA512 8f160a5ec4bd9add83cfc468e9335dcfc9297585180c67263fce18235a8b748f75205fa5bd5ddd1c34efc65569d94408ba98c6181a2b1ab760f33371f92c3c54 WHIRLPOOL c9396118d4223175f7bb19f095a590b66ba8cdbb9970a1e84b406b7423a6a0b3009491dd6c8b7394d38eee1f796fe290ac88b839e30d6166077ae54fbedc528b
+DIST hashcat-3.40.tar.gz 4099155 SHA256 92627197daa850dc7d723793150801c0791fe31f6c767de68417cee097ad6f4c SHA512 fd8d1927703cfe56c7708c460cc142de4ce64d96b651ed68817b70e6a53cac376a191d16752cbb7cabfcb0230299301173a5eda6c27e6188e79b5d83d758378e WHIRLPOOL bcd25930b4a9616f7a0ebd19575432d98a8abd67083ca434758d40d887ca642418a0305d54e4a0ade662f34059cdc1705097423733d02d97ba1eda0213280e4d
diff --git a/app-crypt/hashcat/hashcat-3.40.ebuild b/app-crypt/hashcat/hashcat-3.40.ebuild
new file mode 100644
index 000000000000..3d4a6f2cc029
--- /dev/null
+++ b/app-crypt/hashcat/hashcat-3.40.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils pax-utils multilib
+
+DESCRIPTION="World's fastest and most advanced password recovery utility"
+HOMEPAGE="https://github.com/hashcat/hashcat"
+SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="custom-cflags video_cards_nvidia video_cards_fglrx"
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #do not strip
+ sed -i "/LFLAGS += -s/d" src/Makefile
+ #do not add random CFLAGS
+ sed -i "s/-O2//" src/Makefile || die
+ export PREFIX=/usr
+ export LIBRARY_FOLDER="/usr/$(get_libdir)"
+ eapply_user
+}
+
+src_compile() {
+ default
+ pax-mark -mr hashcat
+}
+
+src_test() {
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ elif use vidia_cards_fglrx; then
+ addwrite /dev/ati
+ fi
+ #this always exits with 255 despite success
+ #./hashcat -b -m 2500 || die "Test failed"
+ ./hashcat -a 3 -m 1500 nQCk49SiErOgk
+}