summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-01-15 02:35:23 -0600
committerMatthias Maier <tamiko@gentoo.org>2020-01-15 02:50:43 -0600
commit98bda6b93d184903bd7c91f05f7a1da7b94c5e86 (patch)
tree399e52ba84b5d4702ff5348211eef2926a497ffa /app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
parentsci-mathematics/why3-for-spark: Needs a newer coq version (diff)
downloadgentoo-98bda6b93d184903bd7c91f05f7a1da7b94c5e86.tar.gz
gentoo-98bda6b93d184903bd7c91f05f7a1da7b94c5e86.tar.bz2
gentoo-98bda6b93d184903bd7c91f05f7a1da7b94c5e86.zip
app-crypt/jitterentropy-rngd: new package
Add the jitterentropy-rng userland daemon. This package requires the jitterentropy-rng.ko kernel module to be loaded. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild')
-rw-r--r--app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
new file mode 100644
index 000000000000..bd3a671e48d4
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Jitter RNG daemon"
+HOMEPAGE="http://www.chronox.de/jent.html"
+SRC_URI="https://github.com/smuellerDD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-do-not-strip-and-compress.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ UNITDIR="$(systemd_get_systemunitdir)" install
+}