summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/keynote/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/keynote/files')
-rw-r--r--app-crypt/keynote/files/keynote-2.3-parallel-build.patch14
-rw-r--r--app-crypt/keynote/files/keynote-2.3-qa.patch44
2 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/keynote/files/keynote-2.3-parallel-build.patch b/app-crypt/keynote/files/keynote-2.3-parallel-build.patch
new file mode 100644
index 000000000000..cf4b4926f79d
--- /dev/null
+++ b/app-crypt/keynote/files/keynote-2.3-parallel-build.patch
@@ -0,0 +1,14 @@
+--- keynote-2.3.orig/Makefile.in 2010-02-04 09:51:35.757096194 +0100
++++ keynote-2.3/Makefile.in 2010-02-04 09:52:17.441137132 +0100
+@@ -86,9 +86,11 @@
+
+ k.tab.c: keynote.y header.h keynote.h assertion.h config.h
+ $(YACC) $(YACCFLAGS) keynote.y
++k.tab.h: k.tab.c
+
+ z.tab.c: keynote-ver.y keynote.h header.h config.h
+ $(YACC) $(YACCFLAGS2) keynote-ver.y
++z.tab.h: z.tab.c
+
+ lex.kn.c: keynote.l k.tab.h header.h keynote.h assertion.h config.h
+ $(LEX) $(LEXFLAGS) keynote.l
diff --git a/app-crypt/keynote/files/keynote-2.3-qa.patch b/app-crypt/keynote/files/keynote-2.3-qa.patch
new file mode 100644
index 000000000000..f6b1ff28cdb8
--- /dev/null
+++ b/app-crypt/keynote/files/keynote-2.3-qa.patch
@@ -0,0 +1,44 @@
+Respect CFLAGS, LDFLAGS, and AR.
+
+The better way to fix AR would be to patch configure.in,
+but it is sufficiently old to fail with current autotools.
+--- Makefile.in
++++ Makefile.in
+@@ -27,7 +27,6 @@
+ YACC = @YACC@
+ SSLEAY = @SSLEAY@
+ RM = @RM@
+-AR = @AR@
+ NROFF = @NROFF@
+ TAR = @TAR@
+ TRUE = @TRUE@
+@@ -41,10 +40,10 @@
+ YACCFLAGS = -d -p kn -b k
+ LEXFLAGS2 = -Pkv -s -i
+ LEXFLAGS = -Cr -Pkn -s -i
+-CFLAGS = -O2 -Wall # -g
+ RMFLAGS2 = -rf
+ RMFLAGS = -f
+ NROFFFLAGS = -mandoc
++LDFLAGS = @LDFLAGS@
+
+ SSLCONF = testsuite/openssl.cnf
+ SSLCERT = testsuite/test.cert.pem
+@@ -83,7 +82,7 @@
+ $(RANLIB) $(TARGET)
+
+ $(TARGET2): $(TARGET) $(OBJS2)
+- $(CC) $(CFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
+
+ k.tab.c: keynote.y header.h keynote.h assertion.h config.h
+ $(YACC) $(YACCFLAGS) keynote.y
+@@ -131,7 +130,7 @@
+ -keyout $(SSLKEY)
+
+ test-sample: all $(OBJS3)
+- $(CC) $(CFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
+
+ test-sig: all $(SSLCERT) $(SSLKEY)
+ $(SED) -e 's/--.*//' < $(SSLCERT) > $(SSLCERT).1