summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/kstart
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/kstart')
-rw-r--r--app-crypt/kstart/Manifest1
-rw-r--r--app-crypt/kstart/kstart-4.1.ebuild34
-rw-r--r--app-crypt/kstart/metadata.xml17
3 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/kstart/Manifest b/app-crypt/kstart/Manifest
new file mode 100644
index 000000000000..31fcefe33eeb
--- /dev/null
+++ b/app-crypt/kstart/Manifest
@@ -0,0 +1 @@
+DIST kstart-4.1.tar.gz 269215 SHA256 ad1a71be149d56473319bf3b9bca83a60caa3af463d52c134e8f187103700224 SHA512 74a8a3f2c8d2c95f166f5861fb05a2d659a31db3165e27e81e5cf216bde44809d937ebc00995f89fa3b9df68609e3081303eb30742f5c4d90151b1410f0bd3cc WHIRLPOOL d72c71729eb1eb972eec4329ffb442b02856ddfb73fffca5ffe97f8a8d299155fe5535b0ca59e98197c2b2214bd56e3f5739a42d269fe3dac011556eb588bd13
diff --git a/app-crypt/kstart/kstart-4.1.ebuild b/app-crypt/kstart/kstart-4.1.ebuild
new file mode 100644
index 000000000000..85834d19b06d
--- /dev/null
+++ b/app-crypt/kstart/kstart-4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Modified versions of kinit for refreshing kerberos tickets
+automatically"
+HOMEPAGE="http://www.eyrie.org/~eagle/software/kstart"
+SRC_URI="http://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="afs"
+
+DEPEND="virtual/krb5
+ afs? ( net-fs/openafs )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ econf \
+ --enable-reduced-depends \
+ "$(use_with afs)" \
+ "$(use_enable afs setpag)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman k5start.1 krenew.1
+ dodoc README NEWS TODO examples/*
+}
diff --git a/app-crypt/kstart/metadata.xml b/app-crypt/kstart/metadata.xml
new file mode 100644
index 000000000000..9d8a37e6bcbf
--- /dev/null
+++ b/app-crypt/kstart/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kerberos</herd>
+ <longdescription>Modified versions of kinit that can use srvtabs or
+ keytabs to authenticate, can run as daemons and wake up periodically
+ to refresh a ticket, and can run single commands with their own
+ authentication credentials and refresh those credentials until the
+ command exits.</longdescription>
+ <use>
+ <flag name="afs">
+ Enables afs support which means you can acquire an afs token and
+ set PAGs. It's recommended to set this USE if you need
+ authenticated access to an AFS cell for your daemon/app.
+ </flag>
+ </use>
+</pkgmetadata>