summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-03 20:56:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-03 20:56:28 +0100
commit1d6a2cb83d2c4d929a671db17c9ce69cf9f5c372 (patch)
tree2d716a08f7c46795076473ddba088b9c6898a5c6 /app-crypt/letsencrypt/letsencrypt-9999.ebuild
parentRevert "app-crypt/{acme,letsencrypt}: version bump to 0.1.0" (diff)
downloadgentoo-1d6a2cb83d2c4d929a671db17c9ce69cf9f5c372.tar.gz
gentoo-1d6a2cb83d2c4d929a671db17c9ce69cf9f5c372.tar.bz2
gentoo-1d6a2cb83d2c4d929a671db17c9ce69cf9f5c372.zip
Revert "app-crypt/{acme,letsencrypt}: add ebuilds for latest snapshot"
This reverts commit c37dff06cc5632de78ff283857f211c0361d5582. Breaks acme live ebuild. Repoman complains about description. Huge changes to the ebuild without any communication.
Diffstat (limited to 'app-crypt/letsencrypt/letsencrypt-9999.ebuild')
-rw-r--r--app-crypt/letsencrypt/letsencrypt-9999.ebuild29
1 files changed, 8 insertions, 21 deletions
diff --git a/app-crypt/letsencrypt/letsencrypt-9999.ebuild b/app-crypt/letsencrypt/letsencrypt-9999.ebuild
index f62f8dfda28a..c271da785b44 100644
--- a/app-crypt/letsencrypt/letsencrypt-9999.ebuild
+++ b/app-crypt/letsencrypt/letsencrypt-9999.ebuild
@@ -3,27 +3,18 @@
# $Id$
EAPI=5
+PYTHON_COMPAT=(python2_7)
-PYTHON_COMPAT=( python2_7 )
+EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
-inherit distutils-r1
+inherit git-r3 distutils-r1
-MY_PV="${PV/_pre/.dev}"
-MY_P="${PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="Let's Encrypt client to automate deployment of X.509 certificates"
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
+KEYWORDS=""
IUSE="test"
RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
@@ -40,13 +31,9 @@ RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
nosetests -w ${PN}/tests || die