summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-03 04:15:25 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-03 04:15:43 -0500
commitc37dff06cc5632de78ff283857f211c0361d5582 (patch)
tree08e7e5bc03033d44d124ff1adb7e159f5d9f399f /app-crypt/letsencrypt/letsencrypt-9999.ebuild
parentdev-python/{configargparse,configobj,pythondialog}: add arm love (diff)
downloadgentoo-c37dff06cc5632de78ff283857f211c0361d5582.tar.gz
gentoo-c37dff06cc5632de78ff283857f211c0361d5582.tar.bz2
gentoo-c37dff06cc5632de78ff283857f211c0361d5582.zip
app-crypt/{acme,letsencrypt}: add ebuilds for latest snapshot
Diffstat (limited to 'app-crypt/letsencrypt/letsencrypt-9999.ebuild')
-rw-r--r--app-crypt/letsencrypt/letsencrypt-9999.ebuild29
1 files changed, 21 insertions, 8 deletions
diff --git a/app-crypt/letsencrypt/letsencrypt-9999.ebuild b/app-crypt/letsencrypt/letsencrypt-9999.ebuild
index c271da785b44..f62f8dfda28a 100644
--- a/app-crypt/letsencrypt/letsencrypt-9999.ebuild
+++ b/app-crypt/letsencrypt/letsencrypt-9999.ebuild
@@ -3,18 +3,27 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=(python2_7)
-EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+PYTHON_COMPAT=( python2_7 )
-inherit git-r3 distutils-r1
+inherit distutils-r1
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+MY_PV="${PV/_pre/.dev}"
+MY_P="${PN}-${MY_PV}"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Let's Encrypt client to automate deployment of X.509 certificates"
HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
@@ -31,9 +40,13 @@ RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
python_test() {
nosetests -w ${PN}/tests || die