summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-30 22:57:10 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-30 22:57:10 +0200
commit4b116f407e82b9081464eefb9566d5c3fd2cd988 (patch)
treeb769dfdde187dcb6e86e64eb697da3333c25c6c1 /app-crypt/libnitrokey/libnitrokey-3.5.ebuild
parentapp-crypt/libnitrokey: Update live ebuild (diff)
downloadgentoo-4b116f407e82b9081464eefb9566d5c3fd2cd988.tar.gz
gentoo-4b116f407e82b9081464eefb9566d5c3fd2cd988.tar.bz2
gentoo-4b116f407e82b9081464eefb9566d5c3fd2cd988.zip
app-crypt/libnitrokey: Version bump to 3.5
Bug: https://bugs.gentoo.org/686460 Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/libnitrokey/libnitrokey-3.5.ebuild')
-rw-r--r--app-crypt/libnitrokey/libnitrokey-3.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/libnitrokey/libnitrokey-3.5.ebuild b/app-crypt/libnitrokey/libnitrokey-3.5.ebuild
new file mode 100644
index 000000000000..d3474ddf0dc0
--- /dev/null
+++ b/app-crypt/libnitrokey/libnitrokey-3.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils udev
+
+DESCRIPTION="Support library for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/hidapi:=
+ virtual/udev"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/catch-2.5.0:0 )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
+
+ # actual hardware tests
+ # 1. require a connected Nitrokey
+ # 2. may kill data on your Nitrokey
+ # hence the main testsuite is disabled
+ -DCOMPILE_TESTS=OFF
+ -DCOMPILE_OFFLINE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}