summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2016-06-16 22:36:44 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-28 17:38:44 -0400
commitaab1c58653908468c8182326c1775ae57e38f00d (patch)
tree18c73f5effeb0e4f4b11a2ec55b3781004f9210e /app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild
parentsys-firmware/radeon-ucode: update snapshot to 20160628 (diff)
downloadgentoo-aab1c58653908468c8182326c1775ae57e38f00d.tar.gz
gentoo-aab1c58653908468c8182326c1775ae57e38f00d.tar.bz2
gentoo-aab1c58653908468c8182326c1775ae57e38f00d.zip
app-crypt/libu2f-server: initial commit of U2F server library in C
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild')
-rw-r--r--app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild b/app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild
new file mode 100644
index 000000000000..e05b3ea51d0b
--- /dev/null
+++ b/app-crypt/libu2f-server/libu2f-server-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) server C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-server/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
+ dev-libs/hidapi[${MULTILIB_USEDEP}]
+ dev-libs/json-c[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ myeconfargs=(
+ --disable-h2a # tarball already contains the manpage
+ $(use_enable static-libs static)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ prune_libtool_files
+}