summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-06 14:18:02 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-06 14:19:50 -0700
commitcf87931458b2be5a459e8291fe66a5bff16c922c (patch)
tree6ac4bf924ac7b54774908679b5083cb720ea42f7 /app-crypt/minisign/minisign-0.9.ebuild
parentnet-misc/axel: 2.17.7 drop. (diff)
downloadgentoo-cf87931458b2be5a459e8291fe66a5bff16c922c.tar.gz
gentoo-cf87931458b2be5a459e8291fe66a5bff16c922c.tar.bz2
gentoo-cf87931458b2be5a459e8291fe66a5bff16c922c.zip
app-crypt/minisign: bump to 0.9
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-crypt/minisign/minisign-0.9.ebuild')
-rw-r--r--app-crypt/minisign/minisign-0.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/minisign/minisign-0.9.ebuild b/app-crypt/minisign/minisign-0.9.ebuild
new file mode 100644
index 000000000000..6b1c1c8ca147
--- /dev/null
+++ b/app-crypt/minisign/minisign-0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+ SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_STRIP="${EPREFIX}/bin/true" )
+ cmake_src_configure
+}