summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2017-08-24 10:07:07 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-24 23:56:12 +0200
commit51a6aef7d31ccebc610092afd9e407f6947fd033 (patch)
tree9e2532c6e3cd17a4dcb02ea278570b8d8fec157a /app-crypt/moolticute/moolticute-9999.ebuild
parentnet-wireless/bluez: Drop old (diff)
downloadgentoo-51a6aef7d31ccebc610092afd9e407f6947fd033.tar.gz
gentoo-51a6aef7d31ccebc610092afd9e407f6947fd033.tar.bz2
gentoo-51a6aef7d31ccebc610092afd9e407f6947fd033.zip
app-crypt/moolticute: new package
Closes: https://github.com/gentoo/gentoo/pull/5520 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-crypt/moolticute/moolticute-9999.ebuild')
-rw-r--r--app-crypt/moolticute/moolticute-9999.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/moolticute/moolticute-9999.ebuild b/app-crypt/moolticute/moolticute-9999.ebuild
new file mode 100644
index 000000000000..8609d2fec945
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/raoulh/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/raoulh/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/raoulh/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ >=dev-qt/qtcore-5.6:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}