summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/nistp224/nistp224-0.75-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/nistp224/nistp224-0.75-r1.ebuild')
-rw-r--r--app-crypt/nistp224/nistp224-0.75-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/nistp224/nistp224-0.75-r1.ebuild b/app-crypt/nistp224/nistp224-0.75-r1.ebuild
new file mode 100644
index 000000000000..81d2ed987811
--- /dev/null
+++ b/app-crypt/nistp224/nistp224-0.75-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic fixheadtails
+
+DESCRIPTION="nistp224 performs compressed Diffie-Hellman key exchange on the NIST P-224 elliptic curve"
+HOMEPAGE="http://cr.yp.to/nistp224.html"
+SRC_URI="http://cr.yp.to/${PN}/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+DEPEND=""
+RDEPEND=${DEPEND}
+S="${WORKDIR}/math/${P}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asmfix.patch
+ epatch "${FILESDIR}"/${P}-declare-exit.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-honour-CC.patch
+ ht_fix_file Makefile print*.sh
+}
+
+src_configure() {
+ append-flags -fPIC
+ echo -n "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo -n "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ if use ppc; then
+ # untested
+ echo -n "powerpc" > conf-opt
+ elif use sparc; then
+ # untested
+ echo -n "sparc" > conf-opt
+ else
+ # optiminations for ppro and pentium fail
+ echo -n "idea64" > conf-opt
+ fi
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin nistp224 nistp224-56
+ mv nistp224.a libnistp224.a
+ dolib.a libnistp224.a
+ insinto /usr/include
+ doins nistp224.h
+}