summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuigi 'Comio' Mantellini <luigi.mantellini@gmail.com>2018-04-16 10:22:33 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-26 11:45:38 +0200
commit3f35ce0a62d2bc3686a061c912b275fcddffc48b (patch)
treee100fc58ca0e70adec4ba77fe741f561b7e1d702 /app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild
parentapp-laptop/laptop-mode-tools: cleanup (diff)
downloadgentoo-3f35ce0a62d2bc3686a061c912b275fcddffc48b.tar.gz
gentoo-3f35ce0a62d2bc3686a061c912b275fcddffc48b.tar.bz2
gentoo-3f35ce0a62d2bc3686a061c912b275fcddffc48b.zip
app-crypt/nitrokey-app: Fix resources build.
We need to remove qt5_add_resources() call from CMakeLists.txt becuase AUTORCC mode is enabled. Keeping both flags doesn't permit (in some setup) to include the resources into the final executable producing the following log messages: qt.svg: Cannot open file ':/images/new/icon_NK.svg', because: No such file or directory qt.svg: Cannot open file ':/images/new/icon_NK.svg', because: No such file or directory qt.svg: Cannot open file ':/images/new/icon_NK.svg', because: No such file or directory qt.svg: Cannot open file ':/images/new/icon_NK.svg', because: No such file or directory ... Also translations will not work because the translation files are included by means resources. See also https://github.com/Nitrokey/nitrokey-app/pull/346 Closes: https://bugs.gentoo.org/653158 Closes: https://github.com/gentoo/gentoo/pull/8024
Diffstat (limited to 'app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild')
-rw-r--r--app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild b/app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild
index 045fd86b4d05..1bd4aaad0693 100644
--- a/app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild
+++ b/app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild
@@ -36,10 +36,15 @@ DEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig"
-pkg_postinst(){
+src_prepare() {
+ cmake-utils_src_prepare
+ sed -i '/^qt5_add_resources/d' CMakeLists.txt || die
+}
+
+pkg_postinst() {
gnome2_icon_cache_update
}
-pkg_postrm(){
+pkg_postrm() {
gnome2_icon_cache_update
}