summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-04-11 11:36:10 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-11 11:36:10 +0200
commitf4f91d7261690c13158b4cccadd784f0b0b5bd0f (patch)
tree5d0ce4f6d67325a8a02e48e629e97bcf30f8eacf /app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild
parentapp-crypt/libnitrokey: Add 3.3 release (diff)
downloadgentoo-f4f91d7261690c13158b4cccadd784f0b0b5bd0f.tar.gz
gentoo-f4f91d7261690c13158b4cccadd784f0b0b5bd0f.tar.bz2
gentoo-f4f91d7261690c13158b4cccadd784f0b0b5bd0f.zip
app-crypt/nitrokey-app: Version bump to 1.3
Closes: https://bugs.gentoo.org/634474 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild')
-rw-r--r--app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild b/app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild
new file mode 100644
index 000000000000..3dc9b4162f33
--- /dev/null
+++ b/app-crypt/nitrokey-app/nitrokey-app-1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+DESCRIPTION="Cross platform personalization tool for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/nitrokey-app"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/nitrokey-app"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-crypt/libnitrokey:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"