summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-04 16:03:58 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-04 16:13:53 -0700
commit7f8599060ac7b05af207211ca6379b1285a7038e (patch)
tree370909346ff2b1eb4340baf6e761aa35ff9e1ae8 /app-crypt/openpgp-keys-rust/openpgp-keys-rust-20210504.ebuild
parentprofiles/arch/amd64: mask openjfx for stable again (diff)
downloadgentoo-7f8599060ac7b05af207211ca6379b1285a7038e.tar.gz
gentoo-7f8599060ac7b05af207211ca6379b1285a7038e.tar.bz2
gentoo-7f8599060ac7b05af207211ca6379b1285a7038e.zip
app-crypt/openpgp-keys-rust: new package
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-crypt/openpgp-keys-rust/openpgp-keys-rust-20210504.ebuild')
-rw-r--r--app-crypt/openpgp-keys-rust/openpgp-keys-rust-20210504.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-crypt/openpgp-keys-rust/openpgp-keys-rust-20210504.ebuild b/app-crypt/openpgp-keys-rust/openpgp-keys-rust-20210504.ebuild
new file mode 100644
index 000000000000..7ac4c33144ca
--- /dev/null
+++ b/app-crypt/openpgp-keys-rust/openpgp-keys-rust-20210504.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Rust Language Tag and Release Signing Key"
+HOMEPAGE="https://forge.rust-lang.org/infra/other-installation-methods.html"
+SRC_URI="https://static.rust-lang.org/rust-key.gpg.ascii"
+# https://keybase.io/rust/pgp_keys.asc?fingerprint=108f66205eaeb0aaa8dd5e1c85ab96e6fa1be5fe
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~riscv ~s390 ~sparc x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - rust.asc < <(cat "${files[@]/#/${DISTDIR}/}")
+}