summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-06-02 19:16:38 -0400
committerTim Harder <radhermit@gentoo.org>2017-06-02 19:16:38 -0400
commitea6f0cdfdd9e8ea80a918a3361e2fef82e03bae9 (patch)
tree6b000a72f6c11bc08df9b62034db84ee1222337e /app-crypt/p11-kit
parentmedia-libs/exiftool: version bump to 10.54 (diff)
downloadgentoo-ea6f0cdfdd9e8ea80a918a3361e2fef82e03bae9.tar.gz
gentoo-ea6f0cdfdd9e8ea80a918a3361e2fef82e03bae9.tar.bz2
gentoo-ea6f0cdfdd9e8ea80a918a3361e2fef82e03bae9.zip
app-crypt/p11-kit: version bump to 0.23.7
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/Manifest1
-rw-r--r--app-crypt/p11-kit/p11-kit-0.23.7.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/p11-kit/Manifest b/app-crypt/p11-kit/Manifest
index 50962e99d45f..e8dc818dc7a5 100644
--- a/app-crypt/p11-kit/Manifest
+++ b/app-crypt/p11-kit/Manifest
@@ -1,2 +1,3 @@
DIST p11-kit-0.23.2.tar.gz 1022733 SHA256 ba726ea8303c97467a33fca50ee79b7b35212964be808ecf9b145e9042fdfaf0 SHA512 b665d89f0d752a41b01ec53e29c801c4fdcaf3f21fce524984b10acef0477ad5dbac085edd35ffb747423d0e1e09660b8d29501c979cf54937d3b9d2561cf18f WHIRLPOOL 03ffdce4b96682a7283e9d473f90f2c50be7de5930e1b3cda420bfd09002f3b0bd23351d5edf97f63f6df02545994628d97cf424fc92f66f3ccb04342ddab21c
DIST p11-kit-0.23.5.tar.gz 1074479 SHA256 0d8fed192563c324bb5ace3c068f06558a5569a6e8eb47eee1cd79ada3b1124f SHA512 5276db3c9bb14d5e0441e7b781033b1684edfc1d4da88a9c9ce501ed1f6121918d3afe6725ceb0e2d65fc253c2f9eebf37c3380741de6c1b09cec06ae86417a7 WHIRLPOOL 6d641b7884915e3ebd93ffc6a4364fe43269af0e1bd55419d87cddc9a2074d9217f666a968d6b5bad92b4c20f52d062b0164524585460d41c78c3c590aa3b0ea
+DIST p11-kit-0.23.7.tar.gz 1087009 SHA256 988e7c86f2641b36702503481292ef0686e6b1c39d80b215699b6dbf1024be41 SHA512 c9f492220a963726cd1883c276a4a3e607c07f77a34253797beb9f11e671cadcc1b1fa85baa746a0c5bc3f439a8c362e0b2f86796500215fa05efb5446f2baf8 WHIRLPOOL bca4968ade1621339fa98c896b8e4a72a6dea47f56ca2d99d343dd569427e05da6f04428601966c4a4c64e3d56c58f2a505b291ba6f6765385b7ba1629605066
diff --git a/app-crypt/p11-kit/p11-kit-0.23.7.ebuild b/app-crypt/p11-kit/p11-kit-0.23.7.ebuild
new file mode 100644
index 000000000000..2844a9889097
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.23.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune multilib-minimal
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
+HOMEPAGE="https://p11-glue.freedesktop.org/p11-kit.html https://github.com/p11-glue/p11-kit"
+SRC_URI="https://github.com/p11-glue/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+asn1 debug +libffi +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4[${MULTILIB_USEDEP}] )
+ libffi? ( >=dev-libs/libffi-3.0.0[${MULTILIB_USEDEP}] )
+ trust? ( app-misc/ca-certificates )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # disable unsafe tests, bug#502088
+ export FAKED_MODE=1
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable trust trust-module) \
+ $(use_with trust trust-paths ${EPREFIX}/etc/ssl/certs/ca-certificates.crt) \
+ $(use_enable debug) \
+ $(use_with libffi) \
+ $(use_with asn1 libtasn1)
+
+ if multilib_is_native_abi; then
+ # re-use provided documentation
+ ln -s "${S}"/doc/manual/html doc/manual/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}