summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/pdfcrack/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/pdfcrack/files')
-rw-r--r--app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch22
-rw-r--r--app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch8
2 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch b/app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch
new file mode 100644
index 000000000000..5f39e2695fec
--- /dev/null
+++ b/app-crypt/pdfcrack/files/pdfcrack-0.13-build.patch
@@ -0,0 +1,22 @@
+just use implicit rules so correct variables get used
+
+--- pdfcrack-0.13/Makefile
++++ pdfcrack-0.13/Makefile
+@@ -1,16 +1,11 @@
+-CFLAGS= -Wall -Wextra -O3 -g
++CFLAGS+= -Wall -Wextra
+
+ all: pdfcrack
+
+ pdfcrack: main.o sha256.o rc4.o md5.o pdfcrack.o pdfparser.o passwords.o common.o \
+ benchmark.o
+- gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+
+
+ pdfreader: pdfparser.o pdfreader.o common.o
+- gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+
+
+ clean:
+ rm -f pdfcrack pdfreader testreader *.o
+-
+-%.o: %.c
+- gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $+
diff --git a/app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch b/app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch
new file mode 100644
index 000000000000..7ea168878d1e
--- /dev/null
+++ b/app-crypt/pdfcrack/files/pdfcrack-0.14-cflags.patch
@@ -0,0 +1,8 @@
+--- pdfcrack-0.14/Makefile
++++ pdfcrack-0.14/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS += -Wall -Wextra -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -O3 -g
++CFLAGS += -Wall -Wextra -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
+
+ all: pdfcrack
+