summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-12-16 22:37:38 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2015-12-16 22:37:38 +0200
commit520b00c3b3a314bee9f1ce837363f0b1899840fa (patch)
tree18ce2373510b1d9ac4723b0603c95a757ef89f50 /app-crypt/pdfcrack/pdfcrack-0.15.ebuild
parentsys-apps/memtest86: add fixes from memtest86+ #568292 (diff)
downloadgentoo-520b00c3b3a314bee9f1ce837363f0b1899840fa.tar.gz
gentoo-520b00c3b3a314bee9f1ce837363f0b1899840fa.tar.bz2
gentoo-520b00c3b3a314bee9f1ce837363f0b1899840fa.zip
app-crypt/pdfcrack: version bump
Bug: 568474 Package-Manager: portage-2.2.24
Diffstat (limited to 'app-crypt/pdfcrack/pdfcrack-0.15.ebuild')
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/pdfcrack-0.15.ebuild b/app-crypt/pdfcrack/pdfcrack-0.15.ebuild
new file mode 100644
index 000000000000..440a9e85dbb2
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.14-cflags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}