summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-09-16 23:03:52 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-09-16 23:03:52 +0100
commit742b2aea30f596c0606731ac0eea04428bda17d0 (patch)
tree1419d02beeec57c73198acf3b6f788b6f722e71e /app-crypt/rhash/files
parentdev-perl/Variable-Magic: Version bump (diff)
downloadgentoo-742b2aea30f596c0606731ac0eea04428bda17d0.tar.gz
gentoo-742b2aea30f596c0606731ac0eea04428bda17d0.tar.bz2
gentoo-742b2aea30f596c0606731ac0eea04428bda17d0.zip
app-crypt/rhash: Install headers, fix librhash.so symlink
Sorry, should have spotted these before the earlier commit. Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt/rhash/files')
-rw-r--r--app-crypt/rhash/files/librhash-symlink.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/rhash/files/librhash-symlink.patch b/app-crypt/rhash/files/librhash-symlink.patch
new file mode 100644
index 000000000000..faba2fbf0658
--- /dev/null
+++ b/app-crypt/rhash/files/librhash-symlink.patch
@@ -0,0 +1,38 @@
+From 30c5897a7533b746388f44f3999ad2e23c529364 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Fri, 16 Sep 2016 22:53:51 +0100
+Subject: [PATCH] Handle librhash.so symlink in shared Makefile rules, not
+ static
+
+---
+ librhash/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/librhash/Makefile b/librhash/Makefile
+index a38073f..fc5e5c3 100644
+--- a/librhash/Makefile
++++ b/librhash/Makefile
+@@ -46,18 +46,18 @@ dist-clean: clean
+ install-lib-static: $(LIBRARY) install-headers
+ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBDIR)/
+- ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/$(SOLINK)
+
+ install-lib-shared: $(SONAME)
+ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
+ $(INSTALL_SHARED) $(SONAME) $(DESTDIR)$(LIBDIR)/
++ ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/$(SOLINK)
+
+ uninstall-lib-static: uninstall-headers
+ rm -f $(DESTDIR)$(LIBDIR)/$(LIBRARY)
+- rm -f $(DESTDIR)$(LIBDIR)/$(SOLINK)
+
+ uninstall-lib-shared:
+ rm -f $(DESTDIR)$(LIBDIR)/$(SONAME)
++ rm -f $(DESTDIR)$(LIBDIR)/$(SOLINK)
+
+ install-headers:
+ $(INSTALL) -d $(DESTDIR)$(INCDIR)
+--
+2.8.2
+