summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-04-28 18:26:22 -0400
committerAaron Bauman <bman@gentoo.org>2018-04-28 18:27:16 -0400
commit4582b31ed2cf4323040ccea113a59009ce46fb06 (patch)
tree74298d761e396e53a53b44f1089553d75f81af83 /app-crypt/rhash/rhash-1.3.6-r1.ebuild
parentdev-python/markdown: fix HOMEPAGE(s). (diff)
downloadgentoo-4582b31ed2cf4323040ccea113a59009ce46fb06.tar.gz
gentoo-4582b31ed2cf4323040ccea113a59009ce46fb06.tar.bz2
gentoo-4582b31ed2cf4323040ccea113a59009ce46fb06.zip
app-crypt/rhash: add LibreSSL support
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'app-crypt/rhash/rhash-1.3.6-r1.ebuild')
-rw-r--r--app-crypt/rhash/rhash-1.3.6-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-crypt/rhash/rhash-1.3.6-r1.ebuild b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
index f5d9f3796faa..24efa6705413 100644
--- a/app-crypt/rhash/rhash-1.3.6-r1.ebuild
+++ b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
@@ -12,9 +12,13 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-solaris ~x86-solaris"
-IUSE="debug nls openssl static-libs"
+IUSE="debug nls libressl ssl static-libs"
-RDEPEND="openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+)"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -47,7 +51,7 @@ multilib_src_configure() {
--enable-lib-shared \
$(use_enable debug) \
$(use_enable nls gettext) \
- $(use_enable openssl) \
+ $(use_enable ssl openssl) \
$(use_enable static-libs lib-static)
echo "${@}"