summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-07-19 16:52:12 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2017-07-19 16:52:26 +0300
commit8e05689dbc96788c8935dc6de57348a800413422 (patch)
treea94a63f970fb35d247d7ee8535fa7c0030479a39 /app-crypt/scute/scute-1.5.0.ebuild
parentdev-libs/opensc: version bump (diff)
downloadgentoo-8e05689dbc96788c8935dc6de57348a800413422.tar.gz
gentoo-8e05689dbc96788c8935dc6de57348a800413422.tar.bz2
gentoo-8e05689dbc96788c8935dc6de57348a800413422.zip
app-crypt/scute: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-crypt/scute/scute-1.5.0.ebuild')
-rw-r--r--app-crypt/scute/scute-1.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/scute/scute-1.5.0.ebuild b/app-crypt/scute/scute-1.5.0.ebuild
new file mode 100644
index 000000000000..85adede2192a
--- /dev/null
+++ b/app-crypt/scute/scute-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+SRC_URI="mirror://gnupg/scute/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+DEPEND="
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/pkcs11 \
+ --with-gpgsm=/usr/bin/gpgsm
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}