summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-22 13:53:12 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-22 13:53:12 +0200
commit079865b0cd09dc76add2cc8199ff98d3b10a2939 (patch)
tree88abc1ca5d401932fc65b0546c167605d50d4235 /app-crypt/scute
parentnet-libs/nodejs: remove old (diff)
downloadgentoo-079865b0cd09dc76add2cc8199ff98d3b10a2939.tar.gz
gentoo-079865b0cd09dc76add2cc8199ff98d3b10a2939.tar.bz2
gentoo-079865b0cd09dc76add2cc8199ff98d3b10a2939.zip
app-crypt/scute: Add upstream patch for -fno-common
Closes: https://bugs.gentoo.org/782388 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/scute')
-rw-r--r--app-crypt/scute/files/scute-1.7.0-fno-common.patch52
-rw-r--r--app-crypt/scute/scute-1.7.0.ebuild2
2 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/scute/files/scute-1.7.0-fno-common.patch b/app-crypt/scute/files/scute-1.7.0-fno-common.patch
new file mode 100644
index 000000000000..1554d8d0dfec
--- /dev/null
+++ b/app-crypt/scute/files/scute-1.7.0-fno-common.patch
@@ -0,0 +1,52 @@
+From 49ad2b0e05e3fcb8c8c2e23bb1c6063b390dee02 Mon Sep 17 00:00:00 2001
+From: Damien Goutte-Gattat <dgouttegattat@incenp.org>
+Date: Tue, 30 Mar 2021 22:31:40 +0100
+Subject: [PATCH] Do not declare global variable in header file.
+
+* src/options.h (_scute_opt_t): New typedef.
+(_scute_opt): Declare as extern and move definition to ...
+* src/readconf.c (_scute_opt): here.
+--
+
+This fixes build with gcc-10, which has -fno-common enabled by
+default.
+
+GnuPG-bug-id: 5360
+Signed-off-by: Damien Goutte-Gattat <dgouttegattat@incenp.org>
+---
+ src/options.h | 6 ++++--
+ src/readconf.c | 2 ++
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/src/options.h b/src/options.h
+index 10667db..d74071d 100644
+--- a/src/options.h
++++ b/src/options.h
+@@ -22,10 +22,12 @@
+ #define OPTIONS_H 1
+
+ /* Global options. */
+-struct {
++typedef struct {
+ char *user;
+ int debug_flags;
+-} _scute_opt;
++} _scute_opt_t;
++
++extern _scute_opt_t _scute_opt;
+
+
+ /*-- readconf.c --*/
+diff --git a/src/readconf.c b/src/readconf.c
+index 387a44f..5af2336 100644
+--- a/src/readconf.c
++++ b/src/readconf.c
+@@ -31,6 +31,8 @@
+
+ #include "options.h"
+
++_scute_opt_t _scute_opt;
++
+ static const char *
+ my_strusage (int level)
+ {
diff --git a/app-crypt/scute/scute-1.7.0.ebuild b/app-crypt/scute/scute-1.7.0.ebuild
index ef227673fab2..6aee8c85a67a 100644
--- a/app-crypt/scute/scute-1.7.0.ebuild
+++ b/app-crypt/scute/scute-1.7.0.ebuild
@@ -29,6 +29,8 @@ RDEPEND="
BDEPEND+="
sys-apps/texinfo"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_unpack() {
default