summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-07 11:52:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-07 11:52:50 -0500
commit1c6d473cbdce63cdd870c54c4933222ed7714311 (patch)
tree5cdfcc5493a7f05799a9450dcf55c395b375738e /app-crypt/stoken/stoken-0.90.ebuild
parentsys-libs/ntdb: softening blocker with agreement from the samba team (diff)
downloadgentoo-1c6d473cbdce63cdd870c54c4933222ed7714311.tar.gz
gentoo-1c6d473cbdce63cdd870c54c4933222ed7714311.tar.bz2
gentoo-1c6d473cbdce63cdd870c54c4933222ed7714311.zip
app-crypt/stoken: packaging for bug 539660
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-crypt/stoken/stoken-0.90.ebuild')
-rw-r--r--app-crypt/stoken/stoken-0.90.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/stoken/stoken-0.90.ebuild b/app-crypt/stoken/stoken-0.90.ebuild
new file mode 100644
index 000000000000..e2ca5a126f61
--- /dev/null
+++ b/app-crypt/stoken/stoken-0.90.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="stoken - Software Token for Linux/UNIX"
+HOMEPAGE="http://stoken.sourceforge.net/"
+SRC_URI="http://github.com/cernekee/stoken/archive/v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with gtk)
+}
+
+src_install() {
+ default
+ dodoc CHANGES COPYING.LIB README.md TODO
+ doman stoken.1
+ if use gtk ; then
+ doman stoken-gui.1
+ fi
+}