summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-04-23 14:34:20 -0500
committerSam James <sam@gentoo.org>2022-04-23 22:33:56 +0100
commitd3b455876225abea515c25fefbb4a953a75f2d55 (patch)
tree5929d42683db465b9a042521114f5e7295af00eb /app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
parentapp-crypt/tpm2-totp: Add sublot operator to app-crypt/tpm2-tss dep (diff)
downloadgentoo-d3b455876225abea515c25fefbb4a953a75f2d55.tar.gz
gentoo-d3b455876225abea515c25fefbb4a953a75f2d55.tar.bz2
gentoo-d3b455876225abea515c25fefbb4a953a75f2d55.zip
app-crypt/tpm2-tss-engine: Add sublot operator to app-crypt/tpm2-tss dep
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild')
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..57977d68648f
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="OpenSSL Engine for TPM2 devices"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tss-engine"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-crypt/tpm2-tss:=
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --disable-static \
+ --with-completionsdir="$(get_bashcompdir)"
+}
+
+src_install () {
+ default
+ dobashcomp bash-completion/*
+}