summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-11-20 14:24:47 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-11-23 15:11:24 +0200
commit9037c04d7a936c64439252bc79ab11c45e442d3f (patch)
treec64b6b67f7facdc47ad319d6134d95704dcff2c3 /app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild
parentx11-misc/rofi-calc: version bump to 2.0.0 (diff)
downloadgentoo-9037c04d7a936c64439252bc79ab11c45e442d3f.tar.gz
gentoo-9037c04d7a936c64439252bc79ab11c45e442d3f.tar.bz2
gentoo-9037c04d7a936c64439252bc79ab11c45e442d3f.zip
app-crypt/tpm2-tss-engine: Bump to 1.1.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild')
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild
new file mode 100644
index 000000000000..81489aec4e68
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="OpenSSL Engine for TPM2 devices"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-crypt/tpm2-tss
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --disable-static \
+ --with-completionsdir="$(get_bashcompdir)"
+}
+
+src_install () {
+ default
+ dobashcomp bash-completion/*
+}