summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-02-18 22:45:51 -0600
committerSam James <sam@gentoo.org>2022-02-22 00:21:26 +0000
commit45cc55760105be4324047fcb5d10ed7f089eab00 (patch)
treef356aea82060d283e231f662dcebd26689c953a1 /app-crypt/tpm2-tss
parentapp-misc/spire: remove vulnerable versions (diff)
downloadgentoo-45cc55760105be4324047fcb5d10ed7f089eab00.tar.gz
gentoo-45cc55760105be4324047fcb5d10ed7f089eab00.tar.bz2
gentoo-45cc55760105be4324047fcb5d10ed7f089eab00.zip
app-crypt/tpm2-tss: Bump to 3.2.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tss')
-rw-r--r--app-crypt/tpm2-tss/Manifest1
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-3.2.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss/Manifest b/app-crypt/tpm2-tss/Manifest
index bcc65f26237b..502da1e0675c 100644
--- a/app-crypt/tpm2-tss/Manifest
+++ b/app-crypt/tpm2-tss/Manifest
@@ -1,3 +1,4 @@
DIST tpm2-tss-2.4.5.tar.gz 1439394 BLAKE2B 644d917f545e93dd81856611522329caf4ff038e4ddb04d761f03339cc7308095abc1c9b46a4d601cad67deea6f917ee5e4236c59f3d7042a7fdf2d33630dd3f SHA512 2c92af07ed1cc3665c19479c00ce5608883081f311192a264a4f7d9119c75ac582596c53b910534c4b66dbb60de2ffd3d6218169748332609c2e0fc89f519259
DIST tpm2-tss-2.4.6.tar.gz 1472883 BLAKE2B e007de07c759e77e377f8569c0c5d94ab57597ea3cb452fb598a47c9b404714a7816c86221d4eacad962436fc7625066d4066f433cd957c37b92d51b0455e2a0 SHA512 f7f7f067605ea30661ac891e22095238689856e22e45f11a6b603cb36ed1ae0724ae52d36f0ee5dd72208da8520457667676ae08107647faa5441a0c9b642f7a
DIST tpm2-tss-3.1.0.tar.gz 1584690 BLAKE2B cee2807a030b8bab653045cb11dfc7a6a3f7b1e60c1ce4650ba5f0549f29f36ff307e7d53fb5ef9c950b4dae720bdaf35f7cd1e59ebc07b3f16740035e1d5738 SHA512 8967f172c92f1e3e5ba324dbe8afe07bf1bc7179dd755cef9812105f32634f312ee7cc7dfe8e13af69dc219432463f5dc9b93477743de47aba6af1d70b252405
+DIST tpm2-tss-3.2.0.tar.gz 1629211 BLAKE2B a89aa4d89a50bdfb5a9652874d30e2138747bd022049f2be2d0b56e296329d0c41254033ec3a062dbd64fde54a62e952f54446c551e5788231827cd53fae045a SHA512 cabb411f074dfa94919ba914849aac77a0ac2f50622e28a1406cf575369148774748e0e2b7a7c566ec83561a96d4b883bac5a3b1763f4cf48668a0c5d68c0a23
diff --git a/app-crypt/tpm2-tss/tpm2-tss-3.2.0.ebuild b/app-crypt/tpm2-tss/tpm2-tss-3.2.0.ebuild
new file mode 100644
index 000000000000..f8f73394c96c
--- /dev/null
+++ b/app-crypt/tpm2-tss/tpm2-tss-3.2.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info tmpfiles udev
+
+DESCRIPTION="TCG Trusted Platform Module 2.0 Software Stack"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tss"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc +fapi +openssl mbedtls static-libs test"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="^^ ( mbedtls openssl )
+ fapi? ( openssl !mbedtls )"
+
+RDEPEND="acct-group/tss
+ acct-user/tss
+ fapi? ( dev-libs/json-c:=
+ >=net-misc/curl-7.80.0 )
+ mbedtls? ( net-libs/mbedtls:= )
+ openssl? ( dev-libs/openssl:= )"
+
+DEPEND="${RDEPEND}
+ test? ( app-crypt/swtpm
+ dev-libs/uthash
+ dev-util/cmocka
+ fapi? ( >=net-misc/curl-7.80.0 ) )"
+BDEPEND="sys-apps/acl
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1.0-Dont-run-systemd-sysusers-in-Makefile.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK=" \
+ ~TCG_TPM
+ "
+ linux-info_pkg_setup
+ kernel_is ge 4 12 0 || ewarn "At least kernel 4.12.0 is required"
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable fapi) \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ $(use_enable test integration) \
+ $(use_enable test self-generated-certificate) \
+ --disable-tcti-libtpms \
+ --disable-defaultflags \
+ --disable-weakcrypto \
+ --with-crypto="$(usex mbedtls mbed ossl)" \
+ --with-runstatedir=/run \
+ --with-udevrulesdir="$(get_udevdir)/rules.d" \
+ --with-udevrulesprefix=60- \
+ --with-sysusersdir="/usr/lib/sysusers.d" \
+ --with-tmpfilesdir="/usr/lib/tmpfiles.d"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process tpm2-tss-fapi.conf
+}