summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2017-09-06 15:58:08 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2017-09-06 15:58:08 -0400
commitbb6a86c09e4c206056cb39dcb31f7bac5ce003be (patch)
treef76bb6394512594008c8d656c2b42cc7bfb999dd /app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild
parentdev-libs/libtasn1: arm stable, bug #627014 (diff)
downloadgentoo-bb6a86c09e4c206056cb39dcb31f7bac5ce003be.tar.gz
gentoo-bb6a86c09e4c206056cb39dcb31f7bac5ce003be.tar.bz2
gentoo-bb6a86c09e4c206056cb39dcb31f7bac5ce003be.zip
app-crypt/yubikey-manager: bump to 0.4.4
* Version 0.4.4 (released 2017-09-06) ** OATH: Fix yet another issue with backwards compability, for adding new credentials. * Version 0.4.3 (released 2017-09-06) ** OATH: Fix issue with backwards compability, when used as a library. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild')
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild
new file mode 100644
index 000000000000..d5ad29c57862
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test" # Testing requires RSA keys which are not present in the tarball
+
+RDEPEND="
+ app-crypt/libu2f-host
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"