summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-29 14:08:47 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-29 14:08:47 +0200
commit0d5d0d8bb02f98e5bd55a69b4a80e2a29b303e0f (patch)
tree51690fca5594fa83cd6b9f625a18a15f9a095079 /app-crypt/yubikey-manager
parentdev-python/pyotherside: add py3.10 support (diff)
downloadgentoo-0d5d0d8bb02f98e5bd55a69b4a80e2a29b303e0f.tar.gz
gentoo-0d5d0d8bb02f98e5bd55a69b4a80e2a29b303e0f.tar.bz2
gentoo-0d5d0d8bb02f98e5bd55a69b4a80e2a29b303e0f.zip
app-crypt/yubikey-manager: add 4.0.5
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/yubikey-manager')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-4.0.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 78276c7fcc30..6e3c513aef98 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,2 +1,3 @@
DIST yubikey-manager-3.1.2.tar.gz 116728 BLAKE2B 35b592a26bbe1c2a1c81ddbc5fd5de2693b01dbadd04dd317baa14e5f9c5556ff8622bc36e31983947b4eed272be16d8ae1d55c6e30fe5532c20605c784411c5 SHA512 e7ad46536fae0476ae7ea4d7115ba9ddb0fe158fcd1e1d548524860b2033996f5487f9c948df85586d5b7ea690b51ad8d5b43261a56aa8820940226e0b18acaa
DIST yubikey-manager-4.0.0.tar.gz 137438 BLAKE2B df50113ed46c531032785ceb95ee130a2440f88677b088f70095545528cbceff55db483bc299654beb8d78b3cea94a9c8507751a090a8488cc609680167ec8d7 SHA512 f1684122a9ee8d57fa3644ecf140e39973c822dfcb7cc1d6578a2ef9b09ff9b0078e6e4ab3f0eb6522a08703d095027f9f24bc8ca6fff8b6874f7a9b5e99f1b2
+DIST yubikey-manager-4.0.5.tar.gz 142197 BLAKE2B c48a9c6ae5f2d54b24888b750c6263eb501e68be56beb9fb964e8b9ea5131a608786b2e67d0d092ebcfacb15b09cae3eec19f4271893ac77eba70eee28b6d06d SHA512 f8bddf3121c0c509fcacb56500f1c1885354aff5c00b3347d9ca84cdf1df65276ed744209d9653474909b6cba7595bc5529cd4b37ec34c35d2d2c3cf2ff850de
diff --git a/app-crypt/yubikey-manager/yubikey-manager-4.0.5.ebuild b/app-crypt/yubikey-manager/yubikey-manager-4.0.5.ebuild
new file mode 100644
index 000000000000..b5099ff320d7
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-4.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests require non-existing package makefun
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/fido2:0/0.9[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}
+
+pkg_postinst() {
+ optfeature "'ykman oath'" app-crypt/ccid
+ optfeature "'ykman openpgp'" app-crypt/ccid
+ optfeature "'ykman piv'" app-crypt/ccid
+}