summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGokturk Yuksek <gokturk@binghamton.edu>2015-11-28 03:44:59 -0500
committerGokturk Yuksek <gokturk@binghamton.edu>2015-11-28 03:44:59 -0500
commite69eb361dd801b36aee57ca1f9c82ded705cafa2 (patch)
tree6013bbe7452fd53851c5fb6836ef3cf143d34207 /app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild
parentupdate patch to mesh with upstream (diff)
downloadgentoo-e69eb361dd801b36aee57ca1f9c82ded705cafa2.tar.gz
gentoo-e69eb361dd801b36aee57ca1f9c82ded705cafa2.tar.bz2
gentoo-e69eb361dd801b36aee57ca1f9c82ded705cafa2.zip
app-crypt/yubikey-neo-manager: add dev-python/pycrypto to RDEPEND
This package has a runtime dependency to pycrypto. Without that, it fails with the following error: Traceback (most recent call last): File "/usr/lib/python-exec/python2.7/neoman", line 3, in <module> from neoman import main File "/usr/lib64/python2.7/site-packages/neoman/main.py", line 33, in <module> from neoman.view.main import MainWindow File "/usr/lib64/python2.7/site-packages/neoman/view/main.py", line 30, in <module> from neoman.model.applet import Applet File "/usr/lib64/python2.7/site-packages/neoman/model/applet.py", line 29, in <module> from Crypto.Signature import PKCS1_PSS ImportError: No module named Crypto.Signature Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild')
-rw-r--r--app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..e016c7669fb4
--- /dev/null
+++ b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross platform personalization tool for the YubiKey NEO"
+HOMEPAGE="https://developers.yubico.com/yubikey-neo-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND="
+ dev-python/pyside[webkit,${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ app-crypt/libu2f-host
+ app-crypt/libykneomgr
+ sys-auth/ykpers"
+
+DEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+
+RDEPEND="${CDEPEND}"
+
+DOCS=( NEWS README )
+
+python_test() {
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman scripts/neoman.1
+ domenu resources/neoman.desktop
+ doicon resources/neoman.xpm
+ newicon -s 128 resources/neoman-large.png neoman.png
+}