summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-03-03 00:51:28 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-03-03 00:51:28 +0100
commit0009bd5cdb3a1fb760f30987ea929094f184de3b (patch)
tree96e55553a307adfc978a35e8e2352f1627725f99 /app-crypt
parentapp-containers/podman: Apply musl-1.2.4 largefile workaround (diff)
downloadgentoo-0009bd5cdb3a1fb760f30987ea929094f184de3b.tar.gz
gentoo-0009bd5cdb3a1fb760f30987ea929094f184de3b.tar.bz2
gentoo-0009bd5cdb3a1fb760f30987ea929094f184de3b.zip
app-crypt/cfssl: Apply musl-1.2.4 largefile workaround
Bug: https://bugs.gentoo.org/905997 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/cfssl/cfssl-1.4.1.ebuild5
-rw-r--r--app-crypt/cfssl/cfssl-1.6.0.ebuild5
-rw-r--r--app-crypt/cfssl/cfssl-1.6.4.ebuild3
3 files changed, 11 insertions, 2 deletions
diff --git a/app-crypt/cfssl/cfssl-1.4.1.ebuild b/app-crypt/cfssl/cfssl-1.4.1.ebuild
index b660f9c05730..7541ce49e832 100644
--- a/app-crypt/cfssl/cfssl-1.4.1.ebuild
+++ b/app-crypt/cfssl/cfssl-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,9 @@ PATCHES=(
)
src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
}
diff --git a/app-crypt/cfssl/cfssl-1.6.0.ebuild b/app-crypt/cfssl/cfssl-1.6.0.ebuild
index a9502128157a..3d244721ab37 100644
--- a/app-crypt/cfssl/cfssl-1.6.0.ebuild
+++ b/app-crypt/cfssl/cfssl-1.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,9 @@ PATCHES=(
)
src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
}
diff --git a/app-crypt/cfssl/cfssl-1.6.4.ebuild b/app-crypt/cfssl/cfssl-1.6.4.ebuild
index 947d408f17b3..3d244721ab37 100644
--- a/app-crypt/cfssl/cfssl-1.6.4.ebuild
+++ b/app-crypt/cfssl/cfssl-1.6.4.ebuild
@@ -21,6 +21,9 @@ PATCHES=(
)
src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
}