summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-02-06 10:31:50 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-02-06 10:32:04 -0600
commit035c9e81c7601e25c3bf10416d0af12f5292b109 (patch)
treefa75e3ee90f9a66616fb459b286d5df1084fc9f2 /app-crypt
parentapp-crypt/certbot: drop 2.7.4 (diff)
downloadgentoo-035c9e81c7601e25c3bf10416d0af12f5292b109.tar.gz
gentoo-035c9e81c7601e25c3bf10416d0af12f5292b109.tar.bz2
gentoo-035c9e81c7601e25c3bf10416d0af12f5292b109.zip
app-crypt/acme: drop 2.7.4
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-2.7.4.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index c8e1995d63c0..91edfdbab5f9 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,2 +1 @@
-DIST certbot-2.7.4.gh.tar.gz 1345476 BLAKE2B 9050765a345ab1195edbf6f0194b9442f64d468f34d26a6ec780901850835ce488d235b72d0a4d5079f29b433454b2bd24e1c0b2001e136216734e353f3627d9 SHA512 4363a2b9cc0d80692c26b6e4e82d7b2f1b57145f82603d33591cc6d00f08a920a2f9b963268c9a24211492e570fc8a91a1c64ccbcd4a44068e30590ce0a1d369
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
diff --git a/app-crypt/acme/acme-2.7.4.ebuild b/app-crypt/acme/acme-2.7.4.ebuild
deleted file mode 100644
index 2b88a178379f..000000000000
--- a/app-crypt/acme/acme-2.7.4.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-PARENT_PN="certbot"
-PARENT_P="${PARENT_PN}-${PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/certbot/certbot/archive/v${PV}.tar.gz
- -> ${PARENT_P}.gh.tar.gz
- "
- KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv x86"
-fi
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="
- https://github.com/certbot/certbot
- https://letsencrypt.org/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
-BDEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
-# to avoid broken 23.1.0.
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
- >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest