summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /app-crypt
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/acme-0.39.0.ebuild1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild1
-rw-r--r--app-crypt/certbot/certbot-0.39.0.ebuild1
-rw-r--r--app-crypt/heimdal/heimdal-7.5.0.ebuild1
-rw-r--r--app-crypt/heimdal/heimdal-7.6.0.ebuild1
-rw-r--r--app-crypt/heimdal/heimdal-7.7.0-r1.ebuild1
-rw-r--r--app-crypt/libsecret/libsecret-0.18.6-r1.ebuild3
-rw-r--r--app-crypt/libsecret/libsecret-0.18.8.ebuild1
-rw-r--r--app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild3
-rw-r--r--app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20190427.ebuild1
-rw-r--r--app-crypt/pkcrack/pkcrack-1.2.2-r1.ebuild3
-rw-r--r--app-crypt/qca/qca-2.2.0.ebuild1
-rw-r--r--app-crypt/qca/qca-2.2.1.ebuild1
-rw-r--r--app-crypt/swtpm/swtpm-0.2.0.ebuild1
-rw-r--r--app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1.ebuild1
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild1
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.0.ebuild1
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild1
18 files changed, 21 insertions, 3 deletions
diff --git a/app-crypt/acme/acme-0.39.0.ebuild b/app-crypt/acme/acme-0.39.0.ebuild
index e5015f90babf..f0658af138c4 100644
--- a/app-crypt/acme/acme-0.39.0.ebuild
+++ b/app-crypt/acme/acme-0.39.0.ebuild
@@ -22,6 +22,7 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
diff --git a/app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild
index 492ef9bf4862..c45e7e40dd95 100644
--- a/app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-0.39.0.ebuild
@@ -22,6 +22,7 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
>=app-crypt/certbot-0.39.0[${PYTHON_USEDEP}]
diff --git a/app-crypt/certbot/certbot-0.39.0.ebuild b/app-crypt/certbot/certbot-0.39.0.ebuild
index fc61e30313d3..33e7e1409f34 100644
--- a/app-crypt/certbot/certbot-0.39.0.ebuild
+++ b/app-crypt/certbot/certbot-0.39.0.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
diff --git a/app-crypt/heimdal/heimdal-7.5.0.ebuild b/app-crypt/heimdal/heimdal-7.5.0.ebuild
index 69ed2cbc132e..0ad3f4972ad7 100644
--- a/app-crypt/heimdal/heimdal-7.5.0.ebuild
+++ b/app-crypt/heimdal/heimdal-7.5.0.ebuild
@@ -16,6 +16,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh ~sparc x86"
IUSE="afs +berkdb caps hdb-ldap ipv6 libressl otp +pkinit selinux ssl static-libs test X"
+RESTRICT="!test? ( test )"
CDEPEND="
ssl? (
diff --git a/app-crypt/heimdal/heimdal-7.6.0.ebuild b/app-crypt/heimdal/heimdal-7.6.0.ebuild
index 3913a7b6e5f7..9fa8c8515999 100644
--- a/app-crypt/heimdal/heimdal-7.6.0.ebuild
+++ b/app-crypt/heimdal/heimdal-7.6.0.ebuild
@@ -17,6 +17,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ~ppc64 s390 ~sh ~sparc x86"
IUSE="afs +berkdb caps gdbm hdb-ldap ipv6 libressl +lmdb otp selinux ssl static-libs test X"
+RESTRICT="!test? ( test )"
CDEPEND="
ssl? (
diff --git a/app-crypt/heimdal/heimdal-7.7.0-r1.ebuild b/app-crypt/heimdal/heimdal-7.7.0-r1.ebuild
index 86cc8ddc99fb..21fe1180298f 100644
--- a/app-crypt/heimdal/heimdal-7.7.0-r1.ebuild
+++ b/app-crypt/heimdal/heimdal-7.7.0-r1.ebuild
@@ -17,6 +17,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="afs +berkdb caps gdbm hdb-ldap libressl +lmdb otp selinux ssl static-libs test X"
+RESTRICT="!test? ( test )"
CDEPEND="
ssl? (
diff --git a/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild b/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild
index dd16f40b9cc5..8ba2cb353b9b 100644
--- a/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild
+++ b/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
SLOT="0"
IUSE="+crypt +introspection test vala"
+RESTRICT="!test? ( test )"
# Tests fail with USE=-introspection, https://bugs.gentoo.org/655482
REQUIRED_USE="test? ( introspection )
vala? ( introspection )"
diff --git a/app-crypt/libsecret/libsecret-0.18.8.ebuild b/app-crypt/libsecret/libsecret-0.18.8.ebuild
index 5f16a860860c..6a79b234fee0 100644
--- a/app-crypt/libsecret/libsecret-0.18.8.ebuild
+++ b/app-crypt/libsecret/libsecret-0.18.8.ebuild
@@ -14,6 +14,7 @@ LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
SLOT="0"
IUSE="+crypt +introspection test +vala"
+RESTRICT="!test? ( test )"
# Tests fail with USE=-introspection, https://bugs.gentoo.org/655482
REQUIRED_USE="test? ( introspection )
vala? ( introspection )"
diff --git a/app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild b/app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild
index d6f5837efa5a..15c7230119c7 100644
--- a/app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild
+++ b/app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="BSD-2"
SLOT="0/0.1"
KEYWORDS="amd64 x86"
IUSE="libressl static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="
!libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
diff --git a/app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20190427.ebuild b/app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20190427.ebuild
index 37b6a890725b..b8eebbf0047a 100644
--- a/app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20190427.ebuild
+++ b/app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20190427.ebuild
@@ -12,6 +12,7 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( app-crypt/gnupg )"
diff --git a/app-crypt/pkcrack/pkcrack-1.2.2-r1.ebuild b/app-crypt/pkcrack/pkcrack-1.2.2-r1.ebuild
index 862cdd7871b6..4354930c7646 100644
--- a/app-crypt/pkcrack/pkcrack-1.2.2-r1.ebuild
+++ b/app-crypt/pkcrack/pkcrack-1.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,6 +12,7 @@ LICENSE="pkcrack"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="!<app-text/html-xml-utils-5.3"
BDEPEND="test? ( app-arch/zip[crypt] )"
diff --git a/app-crypt/qca/qca-2.2.0.ebuild b/app-crypt/qca/qca-2.2.0.ebuild
index f895b8ca47c8..bacd8da8b969 100644
--- a/app-crypt/qca/qca-2.2.0.ebuild
+++ b/app-crypt/qca/qca-2.2.0.ebuild
@@ -14,6 +14,7 @@ SLOT="2"
KEYWORDS="amd64 ~arm arm64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="botan debug doc examples gcrypt gpg libressl logger nss pkcs11 sasl softstore +ssl test"
+RESTRICT="!test? ( test )"
BDEPEND="
doc? ( app-doc/doxygen )
diff --git a/app-crypt/qca/qca-2.2.1.ebuild b/app-crypt/qca/qca-2.2.1.ebuild
index 40f66d614dec..cbd6b1639a19 100644
--- a/app-crypt/qca/qca-2.2.1.ebuild
+++ b/app-crypt/qca/qca-2.2.1.ebuild
@@ -14,6 +14,7 @@ SLOT="2"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="botan debug doc examples gcrypt gpg libressl logger nss pkcs11 sasl softstore +ssl test"
+RESTRICT="!test? ( test )"
BDEPEND="
doc? ( app-doc/doxygen )
diff --git a/app-crypt/swtpm/swtpm-0.2.0.ebuild b/app-crypt/swtpm/swtpm-0.2.0.ebuild
index 0ee3facecabc..f2e8e8c41fac 100644
--- a/app-crypt/swtpm/swtpm-0.2.0.ebuild
+++ b/app-crypt/swtpm/swtpm-0.2.0.ebuild
@@ -14,6 +14,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="fuse gnutls seccomp test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="dev-libs/libtpms
dev-libs/openssl:0
diff --git a/app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1.ebuild b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1.ebuild
index 8d21d2b9b4c7..50c48fc0ff29 100644
--- a/app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1.ebuild
+++ b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.1.1.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="sys-apps/dbus:=
dev-libs/glib:=
diff --git a/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild b/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
index c9391925f760..2e1a75c96bbf 100644
--- a/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
+++ b/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
@@ -11,6 +11,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="libressl test"
+RESTRICT="!test? ( test )"
RDEPEND=">=app-crypt/tpm2-tss-2.0:=
net-misc/curl:=
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.0.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.0.ebuild
index b42ef4ae8168..45bd390504e9 100644
--- a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.0.ebuild
+++ b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.0.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="libressl test"
+RESTRICT="!test? ( test )"
RDEPEND=">=app-crypt/tpm2-tss-2.2.2:=
!libressl? ( dev-libs/openssl:0= )
diff --git a/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild b/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild
index 8496a3630e8c..7743ba624f99 100644
--- a/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild
+++ b/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD-2"
SLOT="0/0" # sublot is libtss2-sys number
KEYWORDS="~amd64"
IUSE="doc +gcrypt openssl static-libs test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
gcrypt? ( !openssl )